View Full Version : help! fast tb....


99RS
01-24-2010, 06:52 PM
Got a fast intake n throttle body. peddle to metal and tb wont open all the way. only half way. any solutions?

jdiddyws6
01-24-2010, 07:18 PM
Is the tb cam hitting anything?

99RS
01-24-2010, 07:21 PM
Is the tb cam hitting anything?

nope. its hittin nothin. i was thinkin maybe the throttle cable is too long or the spindle thing is too big. i was jus wanted to know if anybody had same problem and wut did they do to fix it, like if they modified it or bought something to make it work properly...

jdiddyws6
01-24-2010, 07:23 PM
I had the same problem. One of the worm clamps for the bellows was obstructing then movement of the tb cam.

99RS
01-24-2010, 07:23 PM
anyone?

99RS
01-24-2010, 07:24 PM
I had the same problem. One of the worm clamps for the bellows was obstructing then movement of the tb cam.

nothin in da way on mine.

SweetS10V8
01-24-2010, 07:31 PM
Does it open all the way if you take it off the car and try it??

99RS
01-24-2010, 07:44 PM
Does it open all the way if you take it off the car and try it??

it open just only a little bit more. still not all the way.

99RS
01-25-2010, 02:18 AM
anyone?

BlackScreaminMachine
01-25-2010, 09:58 AM
Pics please.

Techincially they only open half way lol. But joking aside, when I had my BBK TB on mt LT1, if I put the cable in the wrong slot (it had 2), it would do the same. Does your Fast have 2 spots where you can connect the Throttle Cable?

SweetS10V8
01-25-2010, 08:08 PM
it open just only a little bit more. still not all the way.Its not put together correctly, someone took it apart and didnt set the return spring right.. Ive seen this before a long time ago.