View Full Version : First Engine Light


JWMayes
06-28-2010, 09:56 PM
Noticed that my engine light came on today, nothing came across the display, don't know if it should have or not. The cars running perfectly fine, I haven't had any problems other than what seem to be computer qlitches. Sometime it doesn't record my RR tire pressure, but it works more often then not. Then maybe once a month, when I get in the car, my seatbelt light stays on, even when the seat belt is latched, then if I turn the car off then back on, the airbag light comes on, which also goes off the next time I drive it. I am going to have to get the code checked tomorrow obviously, but if there is nothing wrong, I really don't want to take it to the dealer to charge me an arm and a leg. This computerized stuff kinda sucks, but I love the car!! Anybody have any ideas, or similar problems?

CenTexSS
06-28-2010, 10:15 PM
Buy a $40 code scanner from a parts store. That way when you do take her to a dealer, you'll know if they're jerking your chain.

TallassJonG
06-28-2010, 10:18 PM
Take it to AutoZone. they will give you a readout for free.

Hawkins04
06-28-2010, 10:23 PM
or advanced they both let you scan for free

JWMayes
06-29-2010, 01:15 PM
Just pulled the code and they said it was the break booster. Apparently the vacuum is less than the vacuum in the intake.

Edit: wiggle a few vacuum lines under the hood and the light went off. Weird..

BuffaloSS
06-29-2010, 01:50 PM
Not bad. Glad it was a free repair.

Regarding the rear TPMS sensor not registering...try re-learning the sensors per the instructions in the manual. If it continues to give you errors, it may need replacing. I had one sensor that the system would "forget" after 15min of highway driving. I traced it down and replaced it (when I painted/installed my wheels) and no more issues.

jabronie78
06-29-2010, 02:12 PM
Congrats on your first SES light. Expect many more.

Count of Monte Carlo
06-29-2010, 07:31 PM
Unfortunately that seat belt/ air bag light action is due to a corrupt air bag controller....I had that exact same problem.

JWMayes
06-29-2010, 09:15 PM
Wow, that sucks, how much did it cost to get fixed? I think I will leave it alone for now, it only happens about once a month, and it clears right up, so I will wait until it gets worse. Hopefully it doesn't fail if I need it, which hopefully doesn't happen.

monte_with_a_LS4
06-29-2010, 09:21 PM
my engine light is on becuz of my hogan dp i konw for sure but maybe i have other codes becuz my tire pressure system doesnt work worth a shit. it doesnt read the pressure with the stock wheels and doesnt even realize that they arent there when my black wheels are on.

Count of Monte Carlo
06-30-2010, 06:38 PM
Wow, that sucks, how much did it cost to get fixed? I think I will leave it alone for now, it only happens about once a month, and it clears right up, so I will wait until it gets worse. Hopefully it doesn't fail if I need it, which hopefully doesn't happen.

The fault actually causes a whole bunch of codes to be stored in the air bag controller also known as SDIM...or SIDM....not sure, and I do not know how much it is to replace. I had it done under warrenty. I cannot imagine it being cheap but I am sure you have all those codes stored...

Count of Monte Carlo
06-30-2010, 06:41 PM
my engine light is on becuz of my hogan dp i konw for sure but maybe i have other codes becuz my tire pressure system doesnt work worth a shit. it doesnt read the pressure with the stock wheels and doesnt even realize that they arent there when my black wheels are on.

The Keyless entry module also received singnals from the TPMS monitors. You could have a fault with that as that is a part that doesn't seem to last...If you have an antenna conntection on the top drivers side of your windshield, then yo have th eold reciever. typically when that fails the remote start will not have much range either.

monte_with_a_LS4
06-30-2010, 06:55 PM
The Keyless entry module also received singnals from the TPMS monitors. You could have a fault with that as that is a part that doesn't seem to last...If you have an antenna conntection on the top drivers side of your windshield, then yo have th eold reciever. typically when that fails the remote start will not have much range either.

ok lol my questions answered

Count of Monte Carlo
06-30-2010, 07:17 PM
yeah there is a new receiver and antenna available. I dont know if the dealer has to do any programming for it to work with the BCM..... The new receiver comes with new remote controls and hidden antenna as well.