Stereo & Electronics - Installed Subs and amp tell me what you think about install?




bryankuhn
03-20-2011, 09:17 PM
Hello all here is my 99 trans am was wondering if you guys think i did a good job with my stereo install that i built. It is a built box for the t-top area and a amp rack for the amp with a trim piece to finish it out on the top. Took me about a week to build the whole setup after work every night. I think it turned out pretty good but was wondering what you all thought of it. The subs are rockford fosgate t1 12's and the amp is a memphis pr1.1000. Wow they sound great with this amp. There not even broke in yet but they are moving the hatch on some low bass over 1/2 inch. Well guess thats all i have to say just let me know how you guys think i did and and what you think. Thanks in advance, ramair1999@hotmail.com


ncfastls1
03-20-2011, 10:08 PM
Damn man nice job. That looks like a lot of work, seems to fit perfect though. I think it looks great, although I would probably cover up the white parts with more carpet like you have on the sides/middle. I'm sure it's insanely loud haha, I had two memphis 10's in the hatch with a box kinda like that with memphis amps but my shit got broke into and my amps along with other things were stolen. Had a shitty amp on them for a while then took them out, too much weight.

LS9SkyRedline
03-20-2011, 10:17 PM
Looks good bro.


KEE AUDIO
03-21-2011, 08:50 PM
Nice job man! Looks good.

The Mighty Texan
03-21-2011, 11:10 PM
Looking good man thats a very nice set up you got and looks like you did a clean job

bernarlitt
03-22-2011, 12:52 AM
Damn man nice job. That looks like a lot of work, seems to fit perfect though. I think it looks great, although I would probably cover up the white parts with more carpet like you have on the sides/middle. I'm sure it's insanely loud haha, I had two memphis 10's in the hatch with a box kinda like that with memphis amps but my shit got broke into and my amps along with other things were stolen. Had a shitty amp on them for a while then took them out, too much weight.

The white is showing to match his interior! LOOks BAD ASS!!!! Nice Job. couldnt have done it any better my self:D

pentavolvo
03-22-2011, 07:14 AM
looks good only thing i would do different is flush mount the amp

bryankuhn
03-22-2011, 12:47 PM
Thanks everyone for the kind coments on my install. Yeah did the white that way it matched the white leather camaro seats i put in there couple years ago it matches perfect in person. Also the reason i didnt put the amp flush was because of the high rise trim pieces that go around the subs. The amp is pretty much level with them so they are the same height all the way across this way. Keep the coments coming guys love to hear what you all think i did on the setup.

iWon
03-23-2011, 01:43 PM
Aww come on you know it looks killer :D Nice job dude.

bryankuhn
03-24-2011, 05:19 PM
Yeah i really think it turned out really nice for someone that has never built anything like this before. I use to have a complete stereo system that looked about like this done at a local audio shop that had a build to to the car that looked very good too but this was alot cheaper than that was and it looks almost as good. Thanks everyone for all the kind coments on my system. Just to let everyone know it wasnt very fun to make the box that goes into the t top area with the angles and stuff that had to be cut to get the biggest cubic feet needed for the subs but i got it done. Just wish i could of made a box to still use the t top storage part but since the subs needed this much space i had to do away with that. Guess i will put them in the back seat or leave them at home. Once again thanks everyone, ramair1999@hotmail.com