View Full Version : Need Help! Possible Anti Theft problem?


firehawks_suck
05-11-2011, 11:04 PM
I have a '01 Trans Am. I was waxing it today I pulled forward to far into my spot at my apartment complex so I turned on the key to "aux" and put it in neutral, then I pushed it back with my foot about 2 feet I heard a click I did not think anything of it.
So I waxed my car for about an hour with the radio on. I went to start it up and... click, click, click then the alarm comes on?
I dont think its the battery because the alarm works and the power windows went up?
Please any help is welcome.

firehawks_suck
05-12-2011, 11:30 AM
I figured it out it must have been a low battery from listening to the radio. I charged my jump pack and used it this morning. Started right up so IDK?? Oh well.

Bluestreak
05-12-2011, 02:11 PM
You killed your battery. That's all. Unless you have a deep cycle, I would be very careful about draining the battery like that again - do it more than once (and/or discharge the battery too far, usually below 7-8v) and you may not be able to revive the battery the next time. Get a charger with trickle and 10A settings, and be sure you plug it into the car battery for those times when you're working for a long time with the power on/engine off. The best way to minimize damage and revive a conventional battery with low voltage is on a trickle charge overnight.

firehawks_suck
05-12-2011, 04:18 PM
Thanks for the info I will look into that.

Pete137
05-12-2011, 04:59 PM
Your battery had enough power for the alarm and windows, but it requires more of a charge to crank. If I were you, I'd just invest in a small battery powered radio, or if there's a power outlet that you can reach with an extension cord, even better.