View Full Version : car dying


Aaron_Provost
06-15-2011, 12:25 AM
I've been having this problem for awhile where if I go over a bump the service brake assist light comes on, sometimes the service traction control light will also come on. If I'm braking and go over a bump the service brake assist light will come on and the car will die. I'm thinking it might we one of the wheel hubs but I'm not sure. Any help would be greatly appreciated.

LS1 Racing
06-15-2011, 09:37 AM
Sounds like a hub to me.

gxp-miller-gxp
06-15-2011, 09:38 AM
make sure your terminals and all other electrical connections are good and tight. terminals should be bolted on very tight. if not the hub bearing is possible. my abs,tc and stability control went out because of my hub bearing which i had replaced along with 4 speed sensors

chauncey
06-15-2011, 08:32 PM
i dont know if abs sensors throw codes. i have changed the abs sensor harnesses that connect to the sensor. dorman makes them but not for our car, not sure. gm has problems with them a lot usually strapped to the control arm and when you hit a bump it maybe streches out the wire over time and screws up connection. theyre cheap from dorman thats why i change them first. i dont know about dealer.

TISmyBOOMSTICK
06-22-2011, 05:44 PM
I had a similar problem in my vortec max and they replace my speed sensor and the connector and it was fixed.

GXP25
06-22-2011, 08:33 PM
I've been having this problem for awhile where if I go over a bump the service brake assist light comes on, sometimes the service traction control light will also come on. If I'm braking and go over a bump the service brake assist light will come on and the car will die. I'm thinking it might we one of the wheel hubs but I'm not sure. Any help would be greatly appreciated.

This has plagued me since late last week. It's going into the dealership tomorrow morning. My car doesn't die though.

rvd9431
06-22-2011, 08:54 PM
hub, the speed sensor is built into the hub so you have to replace the whole thing