General Maintenance & Repairs - Weird idle problem.. vacuum leak?




View Full Version : Weird idle problem.. vacuum leak?


tspoon8
06-18-2011, 01:03 PM
my 97 trans am has been acting up a bit.. it will drive about half a mile fine until it starts to idle oddly. i can barely get it to rev up and it will keep dying.. does anyone have any suggestions on things it may be? PLEASE HELP!!

the battery gauge isnt twitching so thats fine, but i recently had new wires and plugs put in and it started doin this about a week or two after this happened.


LS6427
06-18-2011, 01:19 PM
What exactly is the idle problem? Do the rpm's increase or decrease?

A vacuum leak causes the rpm's to increase, not stall out.

.

tspoon8
06-18-2011, 01:23 PM
it will try and idle down but the car try's to keep it at 1000rpms, but eventually it just gives up and dies..


Z28Dave
06-18-2011, 01:41 PM
could it be a misfire? i have this problem my car will bog when i first start moving so i have to floor it to keep it from stalling but then for some reason it'll work like nothing happened. i still havent figured it out so i'm chaning out the spark plugs and checking the cam sensor

LS6427
06-18-2011, 01:53 PM
it will try and idle down but the car try's to keep it at 1000rpms, but eventually it just gives up and dies..

Sounds like a bad IAC valve. There's only 3 ways rpm's can go up:
You open the throttle blade
The IAC valve opens
Vacuum leak


You are not opening the TB
A vacuum leak will always be an increase in rpm....NEVER a decrease
The IAC can increase, decrease and stall the engine.

Go buy a new one and see if that fixes it. If it doesn't, return it.

Also.......a failing fuel pump or clogged fuel filter can cause a drop in rpm......but it can't cause an increase in rpm.

.

tspoon8
06-18-2011, 09:40 PM
replaced the iac and still same problem.. any other suggestions?

sjsingle1
06-19-2011, 04:59 PM
i would bet if you still have the stock PCV hose.......it has crapped out.......get a new 1.....or a LS6 VC