General Maintenance & Repairs - 98 formula allergic to throttle




View Full Version : 98 formula allergic to throttle


chrysler kid
09-19-2011, 12:05 AM
Guys I'm having an issue I can't figure out with my formula. The only code being thrown is for mass air low voltage which I replaced with a reman from auto zone.
I reset the battery and the car will barely idle. It lopes like it's firing one cylinder at a time, and if I give it any throttle it absolutely dies.

The idle eventually evens out and the car will idle normally however it only feels like it's making 150 horsepower above 3500 rpms.

I sprayed around the engine with carb cleaner checking for any vacuum leaks but didn't find any.

I'm at my wits end with this thing, about to have it towed to kcm


Slash8915
09-19-2011, 12:22 AM
Bad o2? Burned valve? Maf?

chrysler kid
09-19-2011, 02:13 AM
Just put a new MAF in there. Tried others from one of my other fbodies without success. When i unplug the MAF it doesnt help the car with its issues


LS1TA_956
09-19-2011, 02:17 AM
Maybe somthing wrong with the maf connector make sure its not damaged

chrysler kid
09-19-2011, 02:55 AM
ill take a look at the harness tomorrow but it looked ok when i inspected it.

burnt valve? im not sure, the top end does not make any abnormal noise knocks or ticks but the car runs rich as a saudi

ok so next question, i have heard that if you have an 02 sensor fray on a header it will blow a fuse to the motor that will cause the engine to read low voltage to MAF. anyone remember what fuse that was?

slohemi
09-19-2011, 12:29 PM
It's the engine sensor fuse. When mine popped, the car would get stuck between 1500-2000rpms then settled back down once i stopped. Also felt like a complete turd but it didnt die or misfire. I was throwing codes for the front O2's, MAF,Skip shift, and reverse lockout when mine blew so idk if thats your problem.

patSS/00
09-19-2011, 04:07 PM
If you did a reset (disconnected battery), it will barely idle until it does a relearn, which shouldn't take more than one drive around.
As for the code, need to check for 5V on one of the MAF plug wires (don't recall which one, but with the key on, one will be +5, one will be gnd). Just check with it unplugged, key on but not running.

chrysler kid
09-19-2011, 10:52 PM
Yeah that's the problem though after a hard reset I can't drive it around, it will die.

Checked the engine sensor fuse, seems to look fine. Car is an a4 so no skip shift but it has the same symptoms

chrysler kid
10-30-2011, 09:23 PM
still need help. changed plugs, wires, intake manifold

chevymec
10-30-2011, 09:50 PM
Clogged fuel filter or failing fuel pump? You need to check you basics first and see if you can get a scanner on it to look at readings.

chrysler kid
10-31-2011, 09:01 PM
Changed Maf no improvement
Changed fuel filter no improvement
Changed plugs and wires no improvement
Changed o2 sensors no improvement
Changed throttle position sensor no improvement

No check engine lights

chrysler kid
10-31-2011, 09:05 PM
Oh and when I say changed I mean all new units.

Now it's not making any power at all. It misses when you give it partial throttle, full throttle any throttle. No check engine lights no codes, nothing.

chrysler kid
10-31-2011, 09:08 PM
I forgot to mention I deleted the egr when I did the ls6 swap and it's not triggering a code for that either

metalmilitia606
10-31-2011, 09:19 PM
I forgot to mention I deleted the egr when I did the ls6 swap and it's not triggering a code for that either

You should have got a code on that one. Maybe your issue is computer related.

chevymec
10-31-2011, 09:38 PM
What is the fuel pressure?

Edit: Also you might have a clogged cat. Try taking the upstream O2 sensors out and see if you power comes back.

chrysler kid
10-31-2011, 10:36 PM
car has midlength headers x pipe and o2 sims. i purchased the car from the previous owner who put in a 99 motor and a4 transmission on a 98 a4 engine harness.

im thinking it is computer related. going to see if i can get some one locally to scan the car. when i mash the throttle the car does nothing, acts like it should just be idling.

not sure about fuel pressure. before i changed the o2 sensors the car reeked of fuel coming out the exhaust at idle

chrysler kid
10-31-2011, 11:46 PM
youve got to be kidding me

i ran it around town got it warmed up but the temp gauge still showed cold. so i went under the hood and un plugged the coolant temperature sensor in the head

went and started it up and it did not have the starting issue it has been having. it started instantly and blew a bunch of smoke out of the tail pipes.

so the throttle issue is resolved, the starting issue is resolved, the only problem it has now is the car wont rev past 3 grand which im sure is the computer limiting the rpms because of no temperature reading (the needle on the dash now reads below zero)

going to have to make it to GM tomorrow to order the 3 pin 98 sensor that goes in the head