View Full Version : No heat


Jr.Samples
11-09-2011, 12:05 PM
I have had heat in the last week but when I need it it's not there. I have flushed the heater core twice and it did work for a few days. The engine heats up fine with a new thermostat.

I am wondering if it isn't the dial that goes from cool to hot on the interior control. Is there supposed to be a flap under the dash the moves and lets incoming air pass across the heater core? Any ideas how I can verify or see if this is the case? The defrost, floor , dash vents all work fine but with no heat.

Thank you in advance for any input.

Jr.Samples
11-10-2011, 03:20 PM
Ok I have seen the diagram for the HVAC under dash controls. The question I still have is the flap that opens and closes off the heater core vacuum operated like the other controls for floor, defrost, dash vents?

Any input would be greatly appreciated.

Mark_O
11-23-2011, 12:49 AM
If you can hear the actuator closing and opening the air flap then it is not a vacuum problem. If there is no coolant on your passenger side floor your heater core is more than likely clogged.

I had the same problem: we drained the coolant unhooked the heater hoses from the water pump and flushed out the heater coil with an air compressor. Then flushed the whole system and refilled with coolant. Heat now works just like new.

Turns out that Dex Cool overtime coagulates in the heater core and can eventually clog it up.

Jr.Samples
11-24-2011, 05:17 PM
The heater works fine when it is warmer out but not when you need it. Go figure. The core definatly has hot coolant going through This is crazy.