View Full Version : Charge Fluctuations: Alternator?


Crimsonnaire
12-31-2011, 04:58 AM
Hey, guys.

I've experienced charge fluctuations that began with unstable idle RPM and followed by brief appearances of the air bag and ABS lights, finally ending with dash lights dimming and the charge needle moving erratically around, but mostly towards the higher end, and even reaching the red a few times. Now I know it's easy to implicate the alternator as the culprit, but before I go changing that, I would like to ask if it's at all possible for anything outside the alternator that might cause this? Are these alternators designed to counter abnormal power draws with a higher output like I experienced?

This hasn't happened again since that incident and the charge has been normal. Two things I should mention is that my battery has been kinda weak for a while, but still holds enough for me to crank--though barely at times, and there have been times when the charge needle stayed at the engine-off position when the engine is running and remain there for a minute or two before moving to the proper location (between half and third quarter mark; the alternator was definitely charging the whole time).

Any clarification is greatly appreciated. Thanks, and a happy new year to everyone! :cheers:

Guitar
12-31-2011, 09:07 AM
I'd just take it to an auto parts store and get both the battery and alternator checked out.

wssix99
01-01-2012, 09:43 AM
Now I know it's easy to implicate the alternator as the culprit, but before I go changing that, I would like to ask if it's at all possible for anything outside the alternator that might cause this? Are these alternators designed to counter abnormal power draws with a higher output like I experienced?

Great point- yes the system should handle fluctuations. Its probably not your Alternator but the Bridge Rectifier or Voltage Regulator. However... both live inside the alternator case. (The alternator produces AC current, then the bridge rectifier turns the AC current to DC current, and then the voltage regulator cleans up that power and supplies an even voltage to the system.)

As these components go bad, they can be temperamental. If you take the alternator to a parts store to get tested, their tool will evaluate the whole thing and they can give you certainty as to if any of the components are going bad.

This hasn't happened again since that incident and the charge has been normal. Two things I should mention is that my battery has been kinda weak for a while, but still holds enough for me to crank--though barely at times

Poor or inconsistent voltage from the alternator could be impacting your battery charge. Or... the battery could just be old. While you have the alternator out, its easy enough to pop out the battery and get the parts store to test it also. You should have the battery disconnected anyway. (They should have a special tester that tests the cranking capacity of the battery.)

there have been times when the charge needle stayed at the engine-off position when the engine is running and remain there for a minute or two before moving to the proper location (between half and third quarter mark; the alternator was definitely charging the whole time).

When you take your alternator out, check out the exciter wire. (Its the small wire that plugs in to the alternator.) A lot of people break this wire or pull it out of the connector when servicing the alternator. This wire helps the alternator "get going" when starting the engine and could be the reason for your delay in picking up voltage.

dragonrage
01-01-2012, 04:56 PM
wssix gives some good info there. I will add that problems with voltage regulation can actually kill an otherwise-good battery and if it's not charging well then it will be low on power and that is also bad for it. There's a good chance you might need to fix/replace alternator AND replace battery.

Crimsonnaire
01-06-2012, 01:31 AM
Thank you guys very much for the helpful information.

Yeah, the battery's gotta be addressed sooner or later, but learning of the voltage regulator, I think I should change that first to determine whether the alternator needs changing along with the battery. Recently, my water pump went and spewed antifreeze all over the engine bay, and soon I noticed that the charge gauge went to the first quarter mark when the engine was still running. The needle was progressively moving below the first quarter mark with each passing minute, so the spill may have killed the alternator/voltage regulator. First thing I gotta do is replace the water pump, then start the engine and see if the alternator charges. If so, then the regulator is next.

Would any of you happen to know where the regulator is located and what tools I need to replace it?

Thanks again; I'll post an update when I've made progress.

sjsingle1
01-06-2012, 05:14 AM
the regulator is located under that black plastic piece on the back of the alt.....depending on the miles of you alt.......a total rebuild might be better than replacing 1 part......getting quality parts is hard.... lots of cheap china shit out there....you might be better off with a NEW alt.......check out alternatorman on u tube

wssix99
01-06-2012, 08:00 AM
the regulator is located under that black plastic piece on the back of the alt.....depending on the miles of you alt.......a total rebuild might be better than replacing 1 part......getting quality parts is hard.... lots of cheap china shit out there....you might be better off with a NEW alt.......check out alternatorman on u tube

Here's the alternator man video on testing: http://www.youtube.com/watch?v=aOPcnX7V7i4

Not sure if he has one on rebuilding the CS130D, but he does show others.

Crimsonnaire
01-06-2012, 12:45 PM
Thanks very much for the suggestion and for the informative video link!

Being that the alternator would have to be removed to access the regulator, I might as well change the alternator itself. The one I have on now isn't even that old: less than 3 years! I bought it supposedly new from a Meineke shop after the last one failed from power steering fluid leaking onto it. I'll probably get a new alternator from AutoZone that comes with a lifetime warranty.

By the way, is it possible to swap alternators from above the engine bay? Cause if so, I could conveniently do that when I have the water pump out.

wssix99
01-06-2012, 03:26 PM
I highly recommend buying new alternators. (I've had many a problem over the years with remans.)

You don't want to do the alternator from the top. Much easier from below. (The power steering pump is in the way from the top.)

Crimsonnaire
01-23-2012, 05:34 AM
OK. Went to Pep Boys today and they determined that, 1, someone had carelessly rewired the alternator harness into a single wire setup, and 2, that this was what caused the premature failure of my alternator by having the undispensed power cause the inner component to "spin faster." Therefore, they insisted on not installing their new alternator because it would fail prematurely also, and that the harness has to be addressed first. Do you guys agree with this logic?

A few facts to add: First, that alternator lasted me 3 years--albeit not that many miles (about 7k miles). Second, I've come across remanufactured alternators for the LS1 that was labeled "Single wire." Third, isn't the alternator RPM forcefully regulated by the serpentine belt anyway?

By the way, they put the old alternator back in, and it incidentally ran perfectly normal even though they presumably did nothing to it... Still gonna address it though; just gotta get clarification on the single wire/multiple wire issue. Also, is the alternator bolted in place by 2 spots or 3? A cracked metal piece came off with the alternator still bolted in, and they suggested that it must've cracked off the infrastructure.

RyanEricW
01-23-2012, 05:44 AM
higher amp alternator is needed

Crimsonnaire
01-23-2012, 06:05 AM
http://i7.photobucket.com/albums/y265/Imperious825/Cimg1534a.jpg

Cracked piece at 11 o'clock, and the single wire connector at 7 o'clock.

Forgot to mention: I've got an aftermarket stereo system installed. Could the modification have been made for that?

http://i7.photobucket.com/albums/y265/Imperious825/Cimg1120a.jpg
(Tsunami)

wssix99
01-24-2012, 07:53 AM
OK. Went to Pep Boys today and they determined that, 1, someone had carelessly rewired the alternator harness into a single wire setup, and 2, that this was what caused the premature failure of my alternator by having the undispensed power cause the inner component to "spin faster." Therefore, they insisted on not installing their new alternator because it would fail prematurely also, and that the harness has to be addressed first. Do you guys agree with this logic?

The logic sounds plausible, but your picture indicates a normal setup. I see the exciter wire plug at the bottom of the picture. Was it hooked up? If so, I'd get a second opinion. Without knowing exactly what's going on, I'm not sure if it would be wise to make a call to go to a single wire alternator.

Crimsonnaire
01-24-2012, 09:37 AM
Yes, that's the plug that they pulled out, but the small blurry light dot you see is the single wire that connects to it. They also pointed out to me a second wire that's been joined to that one (further up, not visible in pic) and had tape around the conjunction point. Furthermore, the wire immediately behind that plug is exposed in that the insulation doesn't go all the way into the plug. This might be why the plug was pulled off the wire so easily. The guy just stuffed it back in and used a thin object to press it in before reinstalling the old alternator.

Basically, they want to get a hold of a multiwire harness before changing the alternator, but an obvious alternative I recently realized--and also concurred by a knowledgeable member here--is to simply get a single wire alternator and put that in. I'm hesitant to change the wire setup because one or more of my electrical components might be reliant on the single wire setup, and without knowing more, the only consideration I have is the fact that everything worked as they should, although I've found the driver side window to be somewhat weak.

wssix99
01-24-2012, 04:51 PM
Yes, that's the plug that they pulled out, but the small blurry light dot you see is the single wire that connects to it.

That's not a "single wire" system. Its your exciter wire. Single wire (self exciting) systems have no exciter and that "single" wire is just the big one hooked up to the battery. The exciter wire on our cars just ooks weird because its just one wire in a three conductor plug. That's normal and the way it came from the factory.

They also pointed out to me a second wire that's been joined to that one (further up, not visible in pic) and had tape around the conjunction point.

Replacing the exciter is a common repair. Someone previously probably broke the exciter (its fragile) and put a new wire/connector on.

Furthermore, the wire immediately behind that plug is exposed in that the insulation doesn't go all the way into the plug. This might be why the plug was pulled off the wire so easily. The guy just stuffed it back in and used a thin object to press it in before reinstalling the old alternator.

Sounds like a bad original repair. You should probably test that exciter wire and do a proper splice of a new wire/plug. This wire is key to getting the alternator to put out a consistent and proper voltage.


Did you get your existing alternator tested? Just take it out and any parts store should be able to hook it up to their testing rig and confirm if its working properly, or not. If its good, all you should need is a new exciter wire. If its bad, you could have a bad exciter wire and alternator.

Just the bad exciter wire could be the cause of all your issues. Did I mention that your exciter wire might be bad?

Crimsonnaire
01-25-2012, 04:37 AM
Well, this is certainly a surprise! I must say I'm relieved to find out that I've got the stock setup, because I will be able to use the new alternator from Autozone which has a lifetime warranty.

I never considered the possibility of the exciter wire being bad, but even if it is bad, could it cause power fluctuations that occur in sync with a metallic grinding sound from the alternator? About the tape on the wire, I mean that there appears to be a second wire spliced into it, and that's where the tape is. In other words, the exciter wire appears to part into two at the point where the tape is. Is a stock exciter wire supposed to be like that?

Anyhow, would there be any risk in running a single wire alternator on a multiwire setup?

wssix99
01-25-2012, 09:35 AM
I never considered the possibility of the exciter wire being bad, but even if it is bad, could it cause power fluctuations that occur in sync with a metallic grinding sound from the alternator?

Yes it could - but it could be other things also. You'll need to have the physical alternator tested and test the exciter wire to confirm. (I've never tested my own, but understand that the exciter wire should provide 12V at all times when the car is running. Maybe someone else can confirm here?)

About the tape on the wire, I mean that there appears to be a second wire spliced into it, and that's where the tape is. In other words, the exciter wire appears to part into two at the point where the tape is. Is a stock exciter wire supposed to be like that?

Can you post a picture? Where does the other wire go to?

Anyhow, would there be any risk in running a single wire alternator on a multiwire setup?

I'm not an expert here, but I'd think that the stock alternator would give "cleaner" (more stable) power over single wire, self exciting, alternator. The car's computers and other electronics may not be happy with a single wire.