Drag Racing Results - Ouch!!!!!!!!!!




View Full Version : Ouch!!!!!!!!!!


2camaros6702
01-09-2012, 10:03 AM
http://www.youtube.com/watch?v=1yTWE2VFj_E&feature=youtube_gdata_player

Updated pics at the end


Nick V.
01-09-2012, 10:06 AM
http://www.youtube.com/watch?v=1yTWE2VFj_E&feature=youtube_gdata_player

i found your problem XD.

what rims are those?

2camaros6702
01-09-2012, 10:20 AM
Convo Pro's.


crashinaz
01-09-2012, 11:04 AM
Took the output shaft with it huh? That sucks.

N2RACINGLS1's
01-09-2012, 05:20 PM
More than likely it got more parts in the transmission, hopefully it won’t be too bad.

N2

moge11
01-09-2012, 11:28 PM
output looks fine to me.. it wouldnt be sitting there like that if it was broken. looks like it just broke the u-joint..

2camaros6702
01-10-2012, 06:11 AM
output looks fine to me.. it wouldnt be sitting there like that if it was broken. looks like it just broke the u-joint..

Output shaft is sitting crooked in the rear and is locked up. It's out of the car and we should have it apart today find out how bad it is.

BOBS99SS
01-10-2012, 06:52 AM
i keep wanting to say meatball problems lol, gotta love that lil troll snooky lol

lazerlemonta
01-11-2012, 06:11 PM
Bummer dude. You looked like you was gonna haul ass

dannyz
01-11-2012, 08:34 PM
Sucks man. How big a stall were you running? Drag radials?

01_ram-air
01-12-2012, 01:21 AM
Sorry to hear Greg. However, it looked good doing it. :D

Car is sounding Mean!

I want to see the earlier wheelie monstah run

I'm not really sure your setup these days... whatcha been cookin' up?
If I had to guess, I'd say..

stock bottom end
heads/big cam
150-175 dry shot
12 bolt
3.73s
28" 295 radials on Convo Pros
full suspension
built 4L60E... although it's just a matter of time before you get a TH400. Just wait until you launch off the Transbrake!!!
4000 stall... FTI? (Make sure you go through your old converter before you put it in the new trans)

Are you ready to get whooped on the 21st?? Or do I need to drive to Lakeland to take care of business? :engarde:

2camaros6702
01-12-2012, 06:41 AM
Sorry to hear Greg. However, it looked good doing it. :D

Car is sounding Mean!

I want to see the earlier wheelie monstah run

I'm not really sure your setup these days... whatcha been cookin' up?
If I had to guess, I'd say..

stock bottom end
heads/big cam
150-175 dry shot
12 bolt
3.73s
28" 295 radials on Convo Pros
full suspension
built 4L60E... although it's just a matter of time before you get a TH400. Just wait until you launch off the Transbrake!!!
4000 stall... FTI? (Make sure you go through your old converter before you put it in the new trans)
Are you ready to get whooped on the 21st?? Or do I need to drive to Lakeland to take care of business? :engarde:

You pay entirely too much attention to a few other peoples setups!!LOL. I think you hit everything right on the head and yes I am trying to get the 175 shot down the track as of last weekend but we see how that turned out. Everything up till now has been the 125 shot that has been in there for the past 8 years! I now want that elusive 9sec slip and you were there when I got my 10sec slip so if it is fixed by the 21st let’s try and do it again. The first pass of the night was a 7.0 @ 74mph I let out on the hit and then just drove it the rest of the way down the track. We can only hope.

82cetuner
01-12-2012, 08:27 AM
hey thats funny that you guys are from lakeland FL, I think I owned a truck that came from that drag strip.

a long time ago I purchased a 1992 Ford F150 that had pace car stickers all over it it was a inline 6 with a 5 speed manual and it had lakeland FL race track pace truck or something it was red, maybe you guys can ask the owners if they ever owned that truck. I bought it in NC btw

2camaros6702
01-12-2012, 09:48 AM
hey thats funny that you guys are from lakeland FL, I think I owned a truck that came from that drag strip.

a long time ago I purchased a 1992 Ford F150 that had pace car stickers all over it it was a inline 6 with a 5 speed manual and it had lakeland FL race track pace truck or something it was red, maybe you guys can ask the owners if they ever owned that truck. I bought it in NC btw

It was probably from Lakeland International Speedway. It was the track right beside the drag strip two different owners and it closed a few years back.

shortdog
01-12-2012, 01:16 PM
It looked like the "shock" found the weak point. I can't tell from the pic, but was that a stock driveshaft?

2camaros6702
01-13-2012, 06:16 AM
It looked like the "shock" found the weak point. I can't tell from the pic, but was that a stock driveshaft?

Nope! Aftermarket steel 3" with cheap U-joints. I twisted the stock Alum shaft in two a long time ago.

2camaros6702
01-13-2012, 08:42 AM
Looks like I need a new housing!!

meine96ws6
01-13-2012, 04:28 PM
damn, i could only imagine the pressure on that launch on the drivetrain..and btw... your sounds sick!

N2RACINGLS1's
01-13-2012, 08:03 PM
I was afraid of that. Good luck on getting everything fixed.

N2

gator's 99TA
01-14-2012, 09:39 PM
I need the hit. My car has never ever wheelied. Nothing like this. Must be that WCR influence. I can barely get a piece of paper under the front driver tire on the nitrous!

1Bad97WS-6
01-15-2012, 08:57 AM
car sounds awesome.

2camaros6702
01-31-2012, 06:33 AM
Finally had the chance to get everything apart to see what was broke inside!

gator's 99TA
01-31-2012, 08:59 AM
Its not supposed to look like that.

:p