Generation IV External Engine - Run map sensor on front or back Fast 102




1nastyss
02-05-2012, 04:10 PM
Whats up fellas, ive got a Fast 102 being ported by Tony Mamo to go on my new stroker motor, my question is , ive read where alot of guys are having issues with the map sensor being on the back of the 102 coming in contact with the fire wall , are most of u guys just relocating it to the front by extending the harness or is there a trick to running it on the back without issues. Personally it looks cleaner on the back out of the way, but i dont want it to break off .....let me know fellas


djfury05
02-05-2012, 04:11 PM
Mine is on the front.. not sure of the issues on the back I haven't looked into it.. I think it would look better on the back too but since your intake will be black it will kind of blend now.

Undertow74
02-05-2012, 04:18 PM
Its been taking me forever because i have been busy and on leave and stuff, but i should be putting my new waterpump/fast 102 back on tomorrow. I made a extension for my map and am mounting it on the front also, so i dont have to deal with it back there against the firewall. Yea, it does look better hidden i agree, but for me its just easier to get to and one less thing i have to deal with bolting the intake back down.


ramairws6
02-05-2012, 05:09 PM
On my LS7 headed Fast 102 setup it was tight but doable. As soon as i did my buds cathedral port Fast it was a huge issue. Moved it to the front and was good to go. Both of these were F-Body cars by the way:eyes::lurk:

1nastyss
02-05-2012, 05:55 PM
Gotcha, im gonna go ahead and mount it on the front , i can clean it up with some braided loom or something

Undertow74
02-05-2012, 05:59 PM
Yea i have my extension in some grey cloth loom that is really tight to the wires and small, i can run in between the intake and fuel rails, so you cant really notice the wires

Br1_ss
04-14-2013, 01:17 PM
did your fast 102 come with block off plates for the rear? If not, what did you guys use to plug that hole for the MAP sensor for the rear?

ramairws6
04-14-2013, 03:06 PM
Neither hole was drilled from new. This way you have a choice front or back

Br1_ss
04-15-2013, 11:08 AM
mine wasn't new so the rear was drilled out. I just plugged it with an AN fitting

FAST Beast
04-15-2013, 12:19 PM
You will get a better reading on the back of the intake. If you are running a MAF tune it really want matter front or rear but if you are going with SD, it will work alot better on rear.

Br1_ss
04-15-2013, 01:26 PM
with F-body cars the sensor hits the firewall.

FAST Beast
04-15-2013, 01:33 PM
I have a o2 WS6, mine is mounted on back of a FAST LSXr with no modifications and it clears the firewall plugged in, but there is not much room to spare, can be done.

Br1_ss
04-16-2013, 11:06 AM
You will get a better reading on the back of the intake. If you are running a MAF tune it really want matter front or rear but if you are going with SD, it will work alot better on rear.

Sounds good!! I'm running a turbo kit with the MAF delete so the MAP sensor behind the TB will work perfect!!!
Thanks for looking out.