LS4 Performance - Trans having issues




View Full Version : Trans having issues


k9t8m
02-20-2012, 02:08 PM
Well i guess i have been lucky so far. 81k mi without any trans problems (that i know of, nought with 51k) now it is starting to jerk and slip pretty often. Im taking it to the stealership tonigjt but am afraid what they might find.

I guess i am just really concerned it may need a trans and im going to have a really hard time justifying the money on a car that the value has dropped like a rock in the past year.

Wish me luck.....


TheBlizzard
02-21-2012, 12:49 AM
Yeah depending on what they find I would not just buy a reman tranny from the factory, it is going to still have the same factory defects that cause them to prematurely fail. I would suggest getting it rebuilt using the TEP upgrades, install a cooler, shift kit, and a tune and call it a day. You will be way happier in the long run.

k9t8m
02-22-2012, 06:40 AM
Yeah depending on what they find I would not just buy a reman tranny from the factory, it is going to still have the same factory defects that cause them to prematurely fail. I would suggest getting it rebuilt using the TEP upgrades, install a cooler, shift kit, and a tune and call it a day. You will be way happier in the long run.

Thanks for the advice. I guess only time will tell if it holds up or not.


spydog
02-22-2012, 10:28 AM
how much is a TEP tranny or a tep rebuild kit

bigalnash
02-22-2012, 05:50 PM
how much is a TEP tranny or a tep rebuild kit

x2!!!

TheBlizzard
02-23-2012, 05:08 AM
They are like 2700 dollars I think with your core. Its not something you could do yourself unless you are super resourceful and versed in transmissions. They are something for the experts in my opinion. A shift kit you could do but thats about as far as I would go personally and I am fairly car savy.

http://www.tripleedgeperformance.com/

k9t8m
03-02-2012, 05:32 PM
put about 300mi on the car now with the fresh fluid and filter, shits as it should with no issues yet.....

LS1 Racing
03-02-2012, 05:48 PM
put about 300mi on the car now with the fresh fluid and filter, shits as it should with no issues yet.....

Glad to hear it's shitting normally! :D

1CL3ANSUP3RSPORT
03-02-2012, 06:30 PM
put about 300mi on the car now with the fresh fluid and filter, shits as it should with no issues yet.....

Glad to hear it's shitting normally! :D

:lol: :lol: