View Full Version : Running Codes any advice please, can I fix these thigns myself


Tinnybuddha420
04-20-2012, 01:38 PM
P0128- coolant thermastate valve, temperature belowcontrol range
p0171 fuel trim bank 1 system too lean
p0174 fuel trim bank 2 system too lean
p0300 Radnom/multiple cyl., misfire detected
p1637 generator-l-terminal circuit

The car is a 2001 ls1 camaro with a simple catback, any advice please on how to go about these codes

Thanks you

SnIpEz
04-21-2012, 02:44 AM
p0128 - You need to replace your thermostat. Quick easy fix.
p0171 & p0174 - Could be you have a dirty MAF, could be an o2 sensor issue, weak fuel pressure, vacuum leak etc...
p0300 - Could be a lot of things as well. Bad spark plug (or more than 1) spark plug wires, ignition coil, all kinds of things.

If you can find a way to isolate which cylinder(s) is/are misfiring, then you can try swapping coils and seeing if it still misfires. If it does, then the coil was bad, if not, rule that out.

p1637 - Alternator related issue. Alternator could be dead/dying or the exciter wire might need to be replaced.

lt1pwr1
04-21-2012, 09:43 AM
Good advice there from elitesnipez.

Replace your T-stat for the first code. Since you are lean on both banks, very well could be a dirty or bad MAF which could also give you the misfire code as well. I would say try a couple things: Clean or swap out your MAF with another good one to see if the code go aways, spray some carb cleaner around your intake and see if the idle changes. The LS1's go through intake gaskets. As suggested already, you could check fuel pressure as well.