View Full Version : Broke into 7s in the 1/8. (before and after timeslip)


JKB315
04-24-2012, 02:01 PM
Over the winter I installed a fti 3600, spohn torque arm, S60 with 3:73s . Pretty amazing how my mph stayed the same and I got shaved almost 5 tenths off. :) Managed a 7.98. Barely got in the 7s. lol

This was two weeks ago. I ran again last friday and couldn't do it again. Ran a best of 8.01 for the night. Mph was down by 3. So I'll have to figure that out.

Mods are
2001 Z28 125k miles.
slp lid/cold air
180 stat
bassini ory pipe
hooker muffler on stock I pipe
fti 3600 stall
spohn torque arm
bmr control arms + panhard rod
umi relocation brackets
S60 rear with 3:73 gears
Toyo Proxies Drag Radials
Frost tune.

Next up I am doing a ported throttle body, long tubes and maybe a cutout in the i pipe. I am broke from the s60 so I need to save a little dough to buy a y-pipe for the longtubes.

Also I need a retune to do a little tweaking due to the gear change. I tried doing it myself and failed. There is more in the car. Hopefully I can at least gain a tenth from this.

I know I went overkill with the s60 but I blew up my stocker and I wanted something I could abuse and forget about. I'll probably be doing a th350 down the road when I do more to the motor.

Anyhow the two slips are from may 2011 and April of this year.

JKB315
04-24-2012, 02:12 PM
http://www.youtube.com/watch?v=1iv4BdeOpyw

Vid of me and my buddy running side by side last Friday. His 09 Charger is stock. I only ran 8.05 at 83 this run with a 1.75 60 foot. My mph was down most of the night and all I changed was pinion angle and a new idler pulley. Made me wonder what was going on. I made some adjustments and finally got it up to 85 mph before the night was over and ran a 8.01. Track prep was pretty bad that night too.

speedtigger
04-24-2012, 03:49 PM
http://www.youtube.com/watch?v=1iv4BdeOpyw

Vid of me and my buddy running side by side last Friday. His 09 Charger is stock. I only ran 8.05 at 83 this run with a 1.75 60 foot. My mph was down most of the night and all I changed was pinion angle and a new idler pulley. Made me wonder what was going on. I made some adjustments and finally got it up to 85 mph before the night was over and ran a 8.01. Track prep was pretty bad that night too.

What adjustments helped your MPH?

JKB315
04-24-2012, 04:13 PM
Not really sure what did it. I had my throttle body off earlier that day and I took it off at the track and retightened it. I also have been having issues with my speedo being off since the gear change. I tried modifying Frost's tune with my predator programmer to get the shift points more accurate by lowering the mph of the shifts. That messed it up because 1st to 2nd was happing way too early. I finally put it back on the Frost tune and it ran faster. I am sending my pcm off to him soon.

Another discussion my buddy and I had was it wasn't hooking or launching as hard this outting. Since the last outting I have moved the pinion angle trying to rid of some vibration I have had since the s60 install. I think I might have robbed a little power there. So I am taking that back soon to what I had it before.

Overall I can't complain. For a car that still has exhaust manifolds, I am happy with it. I just want to be out of the 8s for good and get deeper into the 7s.