Cadillac CTS-V - NO BRAKE LIGHTS....Help a brother out!




bamacaddy
05-09-2012, 11:54 AM
I had a guy follow me to the store yesterday and after flagging me down I was expecting the whole "Is that the 600 horse pire Caddy I seen on tv?" but instead I got "Hey little buddy you ain't got a single brake light workin on that fancy Caddy-Lak". So as of now I've replaced the BAS (or what the FAWKever) fuse under the rear seat and I replaced both rear bulbs to no avail. Any suggestions on where to troubleshoot next? I'm down in the garage till I get some assistance or advice fellas.
Thanks in advance, Damon.


CTSVBiggie
05-09-2012, 11:58 AM
underhood fuse box?

NeverSatisfied02
05-09-2012, 12:02 PM
I'd guess a fuse or a relay man. Not 100% sure about the electrical on these cars but there are 2 relay/fuse boxes under the carpet under the rear seat too. If u cant find anything wrong in the under hood fuse box, id look there. If they were all working fine before now, it has to be something simple.


bamacaddy
05-09-2012, 12:03 PM
underhood fuse box?

I can't find anything related to brake lights underhood....I've read 5,600 different links/sites and the only thing I can find related to brake lights is the BAS under the rear seat. Maybe I'm just a tard but I've NEVER seen a ride where it didn't just have a fuse that says "Brake Lights" or "Stop Lamps"??? Gottdamn GM engineer that made his fame from the rear ends on these cars must've taken this on as a side project.

ColeGraham
05-09-2012, 12:03 PM
:mullet:

bamacaddy
05-09-2012, 12:05 PM
:mullet:

EXCELLENT REPLY!:swing:

ColeGraham
05-09-2012, 12:13 PM
Damon, with the amount that car has been driven since you owned it, it could a a number of things.

Fuse, Relay, corrosion, wire, etc. Suck to hear the trouble, I hope you get that slut up and running soon.

bamacaddy
05-09-2012, 12:15 PM
Yeah I've put 98,000 miles on it in 2 years....Not too shabby if I do say so. Garage queen my ass!

NeverSatisfied02
05-09-2012, 12:16 PM
Cole... Just sell him the electrical system off ur car. Parting it out is clearly the only way ur gonna get it outta the driveway... One part at a time... ;) haha

ColeGraham
05-09-2012, 12:17 PM
Cole... Just sell him the electrical system off ur car. Parting it out is clearly the only way ur gonna get it outta the driveway... One part at a time... ;) haha

www.fuckyoutaylor.com .org .gov .net

bamacaddy
05-09-2012, 12:22 PM
Cole... Just sell him the electrical system off ur car. Parting it out is clearly the only way ur gonna get it outta the driveway... One part at a time... ;) haha

BAHAHAHAHAAAAAAAA :jest:

Tmac11
05-09-2012, 12:34 PM
Go to the other forum and post your problem. I'm sure darkman will post up a wiring diagram or two.

bamacaddy
05-09-2012, 12:37 PM
I'm not a member......They won't let me in because I have a yahoo.com address and I'm not opening a new email over principal. This has been a pissing contest for a couple years now and I guess I lose LOL. Thanks tho.

ColeGraham
05-09-2012, 01:00 PM
Fuck Cadillac Forums.

bamacaddy
05-10-2012, 03:59 PM
Problem solved. Turned out to be a bad BAS switch that connects to the brake pedal. NOT an easy job for someone that's 6'3" 235 with herniated discs in their neck. Either way after 6 hours of chasing wires and fuses the switch was bad. Worst part is that it wasn't "Not working" all the time. 1/2 the time you depressed the switch it would throw the meter and the other 1/2 it wouldn't. Talk about a nightmare

CTSVBiggie
05-10-2012, 04:01 PM
glad you got it fixored.

bamacaddy
05-10-2012, 06:45 PM
Yeah no doubt....I had to be at the hospital at 530am for an epidural in the neck so getting it fixed was of the upmost importance.

LAYGO
04-10-2013, 09:44 AM
BAS switch eh? I've got no brake lights now too. I can peer into my taillights & see the filaments, but I SERIOUSLY doubt both side bulbs AND the center went out simultaneously. Which led me to think switch/relay or something central to them all. I have running lights/turn signals, just no brakes.

Stone17
04-10-2013, 10:00 AM
BAS switch eh? I've got no brake lights now too. I can peer into my taillights & see the filaments, but I SERIOUSLY doubt both side bulbs AND the center went out simultaneously. Which led me to think switch/relay or something central to them all. I have running lights/turn signals, just no brakes.

Check the brake switch.

Check out the link below. Anti-Lock Brake PDF for the CTS.
https://docs.google.com/file/d/0B_xx9xyVFHcwRE9nRjZSeFZnc2c/edit?usp=sharing

kciaccio
04-10-2013, 01:10 PM
What he said^^^^^^^^^^^^^^

LAYGO
04-10-2013, 01:51 PM
Ok, I just did the cruise control & tap brakes still kills cruise. Is this the same switch?

LAYGO
04-10-2013, 01:57 PM
Check the brake switch.

Check out the link below. Anti-Lock Brake PDF for the CTS.
https://docs.google.com/file/d/0B_xx9xyVFHcwRE9nRjZSeFZnc2c/edit?usp=sharing

Ok, it's 210 pages. Can we narrow it down to a section? BPP Sensor??

Stone17
04-10-2013, 02:03 PM
Ok, it's 210 pages. Can we narrow it down to a section? BPP Sensor??

Check page 7 and 8.

LAYGO
04-10-2013, 02:25 PM
Check page 7 and 8.

Right, Brake Pedal Position Sensor (BPP Sensor).

If it's responsible for killing the cruise, that worked. Now, it might not be working entirely correctly, just enough to kill cruise, but it at least did that.

I will see if there's some diagnostic in the pdf about the BPPS.

meatyCTS-V
04-10-2013, 11:11 PM
I went through this problem a little while ago.

My switch ended up being fine, it was the Neon light bars and specifically the BALLAST for them that ended up shorting out.

Problem: No brake lights, running lights worked fine.

Solution: Replaced corresponding fuse (BAS fuse in box behind drivers seat).

I unplugged the 3rd brake light from the harness to make sure that really was the problem. Fuse didn't blow anymore.

I replaced the neon tubes/ballast with a $25 autozone ricer LED kit after taking apart the whole third brake light.

Good times.

-meaty

LAYGO
04-10-2013, 11:14 PM
I will check the BAS. Is it something that can be purchased at AutoZone?

meatyCTS-V
04-10-2013, 11:19 PM
I will check the BAS. Is it something that can be purchased at AutoZone?

It's just your typical 10-15 amp mini fuse, don't remember which it is.

Take the cover off, you'll find it.

-meaty

LAYGO
04-10-2013, 11:27 PM
it's just your typical 10-15 amp mini fuse, don't remember which it is.

Take the cover off, you'll find it.

-meaty

ohhhh

Stone17
04-11-2013, 06:47 AM
My switch ended up being fine, it was the Neon light bars and specifically the BALLAST for them that ended up shorting out.

Problem: No brake lights, running lights worked fine.

Solution: Replaced corresponding fuse (BAS fuse in box behind drivers seat).


Here the schematic of the BAS relay.

LAYGO
04-11-2013, 12:58 PM
BAS Relay was fine, BAS Fuse was blown. Replaced fuse, lights work.

BAS = stupid name for brake lamps/lights fuse

meatyCTS-V
04-11-2013, 09:56 PM
BAS Relay was fine, BAS Fuse was blown. Replaced fuse, lights work.

BAS = stupid name for brake lamps/lights fuse


Keep an eye on it, mine blew out again shortly after, due to the Ballast box getting moist and shorting out.

-meaty

crete68s
09-24-2013, 06:38 PM
I'm in a similar situation, except only the passenger side brake light is out..??

crete68s
09-24-2013, 07:14 PM
Apparently it was just a short ground. Hardly did anything except hook it back up and it worked.

meatyCTS-V
09-24-2013, 11:51 PM
Lucky you, that it wasn't a big pain in the ass like us lol