View Full Version : Finally Blew My Trans


BigBlackBoxChevy
06-18-2012, 07:34 PM
I can officially join the group. I've been having trouble with my trans for the past 30k miles. The torque converter would lock and unlock when it felt like it.

Today at 71k and change I left work in Warrington. I made it about half a mile before the forward band broke and left me with nothing but reverse. Thankfully I made it off the road safely and waited for my boys to tow me back.

Still under warranty just have to figure out where I want to take it. Hopefully I find a place in Philly. Any suggestions are greatly appreciated.

The_Madcat
06-19-2012, 08:20 AM
If you are getting a stock replacement under warranty, just know that the faulty parts in the old one are the same as what will come in the new one. These transmissions were doomed from the factory to fail. I would recommend that once you have the new trans, contact David @ TEP and buy some replacement parts for that trans. Dave will know what parts you need to replace. With the upgraded parts, you should have a long lasting trans that can take the power our LS4's kick out.

Good luck!

Mr.Angry.GXP
06-19-2012, 10:37 PM
i just bought my GXP with 242,000Km's and the original owner said the trans has never been replaced or ever broke or even slipped, kicked or anything, i asked about any tranny work being down and he said the regular maintenance, the km are all highway, should i be worried? the trans still feels really strong, i am the second owner and before the 1st owner it was the demo car at the dealer, it has 9000km when the original owner bought it

i hope everything is still okay in the trans

SSWHITE07
06-20-2012, 07:05 AM
Hey did your rpms jump up at low speed and then spin the tires kind like a neutral drop? No.e does that sometimes

blkchevyz
06-20-2012, 12:22 PM
Hey did your rpms jump up at low speed and then spin the tires kind like a neutral drop? No.e does that sometimes

thats what mine started doing a year or two ago... progressively got worse

BigBlackBoxChevy
06-20-2012, 09:06 PM
No, at 40mph or faster, at 1-40% throttle the car would bog down, the rpms would fall off, but more throttle than that and it was fine. I had that problem for 2 years, 30k miles or so.

Uptown_GXP
06-20-2012, 10:38 PM
No, at 40mph or faster, at 1-40% throttle the car would bog down, the rpms would fall off, but more throttle than that and it was fine. I had that problem for 2 years, 30k miles or so.

Im in philly too so when you find a decent place. Please let me know. I am getting the feeling my trans is about to bite the dust as well.

blkchevyz
06-21-2012, 09:43 AM
No, at 40mph or faster, at 1-40% throttle the car would bog down, the rpms would fall off, but more throttle than that and it was fine. I had that problem for 2 years, 30k miles or so.

mine started that a few months ago, but once it would bog down the rpms would surge alittle... and if i gave it any more throttle you could feel the torque converter clutch slip then engage again.

once that started happening it went down hill fast.

BigBlackBoxChevy
07-22-2012, 09:13 PM
So I got my car back after 2 weeks of having it in the shop. This thing is awesome now. Shifts better than it ever did before. I was able to get a few things upgraded from stock.

I have nothing but great things to say about the shop that rebuilt my trans. I won't post here where it was done but if you'd like to know feel free to PM me. They were very knowledgeable as far as the LS4 set up. Hopefully this thing last another 70k miles.

blkchevyz
07-23-2012, 09:03 AM
what did you end up upgrading.



sounds good, i cant wait till my transmission shows up, be nice to actually enjoy driving the car again.