View Full Version : 12.65 @ 113.6 cam only.


VandykeT/A
06-29-2012, 07:26 AM
I took my camaro to Bristol last night and ran a 12.65 @ 113.6. I'm running a Nitto extreme drag and a 10 bolt with a M6. The 10 bolt has basically converted to a 1 legger lately so 60 foots suck. I was cutting 2.0s at best and running 12.65 to 12.80. I ran 3 times each time launching a little different trying to improve but only got worse. I think with a good rear and tires I'm in the 12.20 range. Car is 2000 Z28 w/ a Torquer 2 only.

99peweterls1
06-29-2012, 09:26 AM
Your car needs a gear and some tires and t should be a 115+ car cam only bare minimum. Then like you said the 10bolt wont like that.

VandykeT/A
06-29-2012, 10:51 AM
I've got a 4.10 in it. I've heard Bristol is slow. DA last night was right at 4000. A guy I know said he runs 12.2 @ 109 at Bristol and 11.9 at 113 at another track. My heads/cam/ intake car only traps 120.

99peweterls1
06-29-2012, 05:57 PM
Oo well your doing it right then. lol

Somethings up with that mph, that ttack must be slow.

superGTO
07-01-2012, 09:04 AM
Well if you cut your 60 to even 1.8s you are already there. Get better and you have 11 sec potential

GtoSpd
07-01-2012, 12:40 PM
I agree the traps are way down. I ran 12.22 and trapped 114 with just full exhaust, lid, tune, and 3.73s on street tires thru an automatic. You ran in much worse air however, and the M6 is much more of a challenge than my auto. Also, my runs were done at 500' and 70 degree air. DA makes a ton of difference, but that cam should still have you well into the upper teens, even in that air.

ROMERO98Z28
07-10-2012, 02:26 PM
Keeping trying man and have fun

96SOM383
07-16-2012, 10:29 PM
I went Friday night and went 12.17 112mph 1.75 60ft cam only on 245 nitto 555'r
Im an auto car !

senicalj4579
07-17-2012, 01:36 PM
mph is low