View Full Version : who has bought a Fab 9 from MWC and have there ABS/TCS working?


Floorman279
07-06-2012, 08:59 PM
really wanna get one, and my only concern is functioning abs. i saw that mega thread on non working abs with fab 9s, and really wanna keep all that stuff working......MWC says that none of there in house installs have had issues, and they say that they have only heard of 4-5 cases of this happening........anyway, i really just want a simple yes mine worked or no it didnt work and if you were able to get it working

javier1730
07-06-2012, 09:32 PM
I havent drive mine much, but the little driving i have done , i have had 0 issues, its a really nice piece,.its a shame its under the car And no one can see it...And MWC customer service its outstanding. Good luck with your decision.

Egg1456
07-07-2012, 03:55 PM
They installed mine and it works

nocooler
07-07-2012, 07:55 PM
3 channel here and it works perfect

Floorman279
07-08-2012, 10:08 AM
where are all the guys from that big thread on help me get my abs working?

01ssreda4
07-09-2012, 01:49 AM
Mine isnt working on my Strange 12bolt either. 4 channel.

mterveen
07-11-2012, 10:35 AM
i think you need to be more specific, ie 3 ch or 4 ch. i haven't heard of many 3 ch not working but have heard of a number of 4 ch that have problems. also, although it wasn't installed at their business i did order a fully assembled rearend so all i had to do was bolt the sensors back in. i am scheduling an appt with the local gm dealer to have them put there tech2 on it to try to isolate the problem. i hope it is a simple wiring problem vs a structural issue with the mwc rearend since it really is a nice piece.

SweeTbone
07-11-2012, 09:54 PM
I've got nearly all my 500 miles of break in on my MWC 9" (480 miles, 20 left before I drop the fluid.) and everything is working as it should from the first install till now. No issues and I had them build and install everything. The only thing I did was swap over my wheel sensors. 4 channel rear here.

JUSTINSWS6
07-11-2012, 09:56 PM
My mwc works fine 4 channel

sway99bird
07-12-2012, 08:50 PM
I wish I could tell you i'm waiting on mine.....

01ssreda4
07-12-2012, 10:48 PM
Whats the procedure for resetting the ABS light?