View Full Version : UMI Motor Mounts in LS2


DACTARI
07-12-2012, 03:13 PM
Gentlemen:

My ride is a 06 V, and I need motor mounts BADLY. I'm very interested in the UMI Mounts, but I see occasional complaints of unacceptable cabin noise/vibrations. It seems to me that most of those complaining of unacceptable vibrations have the LS2 engine.

I get that typical vibration at around 2K rpm, and at low speeds in parking lots, etc., the car vibrates so that my headliner buzzes. I don't want more of that kind of noise.

So I'm trying this poll thing here, if I can make it work. If you are running UMI mounts, please report to us the type of engine you have and if you have unacceptable vibrations or not.

Thanks brothas!

DAC

FuzzyLog1c
07-12-2012, 03:57 PM
I'm handsome and special. I think.

Anyway, I'm glad you posted this poll. I've had the exact same question for a while. Now that my new camshaft is in, I can tell that my stock motor mounts are getting hammered a lot harder than usual and doubt they'll last a whole lot longer.

Fuzzy_Wuzzy
07-12-2012, 04:04 PM
you can notice a little in the drivers seat. nothing uncomfortable for a performance car.
from the passenger seat you cant notice

DrSpeed
07-12-2012, 04:10 PM
Had to bump up the idle to 900RPM to eliminate the vehicle shake.

Also, picked up vibes in the cruise range, from 2,000-2,500 RPM.

Gabbiani
07-12-2012, 05:12 PM
Had bad shakes below 950ish. I finally got rid of mine and picked up some used UUCs. Sung their praises at first but just grew old.

odthetruth
07-12-2012, 05:13 PM
I have an LS2 with headers. With the UMI mounts, I noticed a small amount of extra vibes and didn't really stress it. It only seemed to get worse after I changed out the trans mount with a CS mount.

With the UMI and CS mount, the vibes are pretty decent. With the stock trans mount, It didn't bother me much if at all.

There is vibes at around 2k-2500, just like mentioned above... I can live with it. Some people can't.
I haven't noticed any noticeable idle vibes... regardless of pre- or post-transmission mount change.

DACTARI
07-12-2012, 07:33 PM
I have an LS2 with headers. With the UMI mounts, I noticed a small amount of extra vibes and didn't really stress it. It only seemed to get worse after I changed out the trans mount with a CS mount.

With the UMI and CS mount, the vibes are pretty decent. With the stock trans mount, It didn't bother me much if at all.

There is vibes at around 2k-2500, just like mentioned above... I can live with it. Some people can't.
I haven't noticed any noticeable idle vibes... regardless of pre- or post-transmission mount change.

Did you have the 2-2.5k vibes before the UMI mounts, but milder?

dudesweet
07-12-2012, 07:41 PM
Here you go. Did a poll about two months ago.
http://ls1tech.com/forums/cadillac-cts-v/1535858-motor-mounts-v1-poll.html

RADEoN
07-12-2012, 08:04 PM
i have my engine out of the car, and will be leaving the UMI's in when I put the new motor in. There's 0 vibration above 900ish RPM.

DACTARI
07-12-2012, 09:17 PM
Here you go. Did a poll about two months ago.
http://ls1tech.com/forums/cadillac-cts-v/1535858-motor-mounts-v1-poll.html

Thanks buddy, I saw that and it was really helpful. I'm just tryi to figure out if the UMIs don't play well with the LS2.

dudesweet
07-12-2012, 09:40 PM
I hear you. That was my concern before I actually purchased the UMI mounts. Anything stiffer than stock will vibrate. But there's unbearable and mild. I'd say you're safe with UMI mounts.

mitchntx
07-13-2012, 04:31 AM
06 LS2 all stock, no mods at all.

Installed UMIs a few weeks ago. There is some noticeable vibration at low idle ... it's kind of like a harmonic.

But it's not at an RPM that is at normal operating speed ... only noticeable at idle.

It's a heckuva lot better than the clunking and banging from the stock units.

furbe
07-13-2012, 07:24 AM
You get used to the UNI mounts and then ”FORGET ABOUT IT!”:guns:

DACTARI
07-13-2012, 07:29 AM
Thanks all for your advice. I wet ahead and bought the UMI mounts.

I notice some of you didn't respond to the poll. Please do so for the V junkies of the future.

DrSpeed
07-13-2012, 12:12 PM
Had bad shakes below 950ish. I finally got rid of mine and picked up some used UUCs. Sung their praises at first but just grew old.

Did you have vibes at 2000-2500 RPM? If so, did it go away with the UUC mounts?