View Full Version : Faint flickering check gauges


SladeX
07-21-2012, 09:20 PM
Oil pressure = 70 psi cold, 55-60 hot
Coolant reads 170F on avg, 185F in stop/go traffic
Fuel full (no check gauges on 98 anyways)
Voltage reads 13.5v (checked with multimeter)

I can see the check gauges flickering ever so slightly... only visible at night, but can see in daytime if I use my phone camera and boost the light sensitivity.

I just switched over to the KG3 truck alternator. It's working, I have consistent voltage, even under full load it reads 13.2-13.5v and all fans running, a/c on, defroster on, stereo blasting, and lights and stepping on brake too...

I'm not sure if this is an issue with the 145 amp generation or something else. I changed the exciter wire, cut it well up the harness, spliced and soldered it then shrink wrapped it to protect it from heat.

Anyone with a KG3 truck alternator notice this too?

Anyone notice this ever and find a culprit for it?

LSXSpeed007
07-22-2012, 03:06 PM
If you have a local Auto Zone they can check for your computer (free) throwing a code. Otherwise there may be a small short turning the light on?
Did you just put the alt in? I have a check gauges light with seemingly no issue, but found my exciter wire fluctuating. (though holding 13+v)

SladeX
07-22-2012, 05:34 PM
SES light not on. I can read codes with hp tuners. Its the check gauges light. I think the new alt is producing more current than stock and triggering the condition that it might be bad, but I did a test at autozone, 15 runs in a row, tested fine. Even now I'm a happy camper with a steady 13.3 v hot under load and in 100 degree heat.

Took a video, now on youtube.

http://youtu.be/pxAlLvrtN-s