View Full Version : Wheels rubbing


krunk99cam
07-29-2012, 04:15 PM
I have had some serious problems with my wheels rubbing and I need help. Here's the story... I've had 17x11 zr1's in the rear for a few years with no problems. I lowered my car last year and installed some LCA and relocation brackets with no problems. Ever since I changed my wheel bearings and bottomed out my wheels have been grinding against my bump stops. So after cutting my bump stops off, adding a adj panhard bar, adding an air lift, and beating the fender wells they still rub. I noticed that it was mostly my passenger side that was rubbing and after adjusting the panhard bar its rubbing the driver side. My rear end seems to be centered and it doesn't always rub. I don't think that my axle tubes are bent either. I'm really stuck and don't know what to do. Any help would be greatly appreciated.

1BadBlkB1tch
07-29-2012, 04:26 PM
i have a buddy with a 98 trans am had same problem but ith 18x10 c5 wheels and he had full umi suspension and what not in rear he took it to a shop we have locally advance driveline and all they did was adjust and dial in his lca's and panhard bar and a couple other little things now he has no rubbing problems at all i kno doesnt help much but just a thought

krunk99cam
07-29-2012, 04:39 PM
I'm about at that point to take it to a shop. Thanks for the info

1BadBlkB1tch
07-29-2012, 06:56 PM
yea no problem i wouldnt waste my time bringing it to a performance shop tho more like a driveline/suspension shop but if the performance shop has scales and what not then cool

NC98Z
07-30-2012, 10:38 AM
If you have poly ends on your aftermarket suspenion and its not rubbing all the time then it might be your poly ends flexing. I replace the ones on mine with Derlin bushings.