Drag Racing Tech - what is wrong with my car?




View Full Version : what is wrong with my car?


hourang
04-09-2004, 08:58 AM
Car: 1998 SS camaro m6 52k mi
Mods: Cutout, clear lid, K&N
tires: Kumho 275/40ZR17 all around, look brand new

Ran it at milan dragway in michigan, i dont have the time sheets in front of me this is from what i remember, their has to be something wrong with my car, i know the 60ft sucks but i shouldnt be this slow.

60ft: 2.314
1/4mi: 14.14 @ 102.24mph

this was my best run out of like 10 runs, i missed third a lot but on my best runs i shifted perfectly. Weather was beautiful, like 57*. The car felt strong as hell, didnt feel like it hesitated at all, pulled like crazy, would bark second everytime, i beat a couple 5.0s no problem, what is wrong with my car?? my last fbody felt like a dog and would hesitate and blow smoke but i still managed to run the same times as this car, i know their is something wrong here. I ran a 2.3 60ft everytime, no matter what i did, i could bog out or squeel the tires, i still ran a 2.3 60ft, even when i felt i got a great launch i would look at the time slip and be like wtf?? im thinking their was seriously something wrong with the track times or something. im pissed i buy this car and it dont even run as good as my 94 z. please help:(


LeadSled1
04-09-2004, 09:02 AM
Ever change the plugs? I had that problem with my 99 Z28 and the factory plugs were toast at 5K miles.

hourang
04-09-2004, 09:10 AM
Ever change the plugs? I had that problem with my 99 Z28 and the factory plugs were toast at 5K miles.

thats what i was thinking but it didnt make sense that there are no hesitations or anything and it pulled so strong. i already bought the plugs i didnt have enough time to install them before the track plus its a pain in the ass and wanted to remove the AIR first.


hourang
04-09-2004, 03:38 PM
anything else cause this problem?

Mustang Hat'r 2
04-09-2004, 03:59 PM
Bad driver? I went from a 14.2 @ 104 to a 13.5 @ 107 when mine was stock with just driving. 2.3 60ft is awful get that down. I went from a 12.3 to 11.7 droping my 60fts into the 1.6's from the high 1.9's.

hourang
04-09-2004, 04:29 PM
Bad driver? I went from a 14.2 @ 104 to a 13.5 @ 107 when mine was stock with just driving. 2.3 60ft is awful get that down. I went from a 12.3 to 11.7 droping my 60fts into the 1.6's from the high 1.9's.

what advise could you give me on a good 60ft? i had no problems pulling 2.0 60fts in my mustang, whats a good way to launch this thing?

hourang
04-09-2004, 04:43 PM
also what should i be shifting at?

goober35
04-09-2004, 05:26 PM
Yaa i know what you problem is. It is slow just like my piece of shit.

nitrousboyWS6
04-13-2004, 02:34 AM
I was there that day too. Milan sucks for hooking the only way I get 1.8 60's is with et streets. What rpm are you shifting at? Did you see that black notch back mustang with a turbo go 8.6's :eek2: .

foff667
04-13-2004, 08:19 AM
Bad driver? I went from a 14.2 @ 104 to a 13.5 @ 107 when mine was stock with just driving. 2.3 60ft is awful get that down. I went from a 12.3 to 11.7 droping my 60fts into the 1.6's from the high 1.9's.

i agree thats its probably just driver error at this point...my friends 02 ran 14.2@103 but its because he doesnt know how to drive lol

hourang
04-15-2004, 01:07 PM
I was there that day too. Milan sucks for hooking the only way I get 1.8 60's is with et streets. What rpm are you shifting at? Did you see that black notch back mustang with a turbo go 8.6's :eek2: .

yeah the best i could muster was a 2.3 60ft, sucks, i was shifting at like 5500rpms? couple runs i tried goin higher but it stops pulling after that, plus i missed 3rd gear on like half my runs, embarrising to run 15s in this car:( yeah that mustang was badd azzz!! weather was great that day:)

nitrousboyWS6
04-16-2004, 01:07 AM
5500 seems low I shift at 6200 off a shift light. Do you have a shift light? If not get one it helps. The stock tack does show the correct rpm it is always a little behind.

hourang
04-16-2004, 12:52 PM
5500 seems low I shift at 6200 off a shift light. Do you have a shift light? If not get one it helps. The stock tack does show the correct rpm it is always a little behind. yeah thats why i shift at 5500 cuz i know the rpms are behind, the car doesnt get any faster past that so i just shift then, i definately want a shift light, where did you get yours and how much they run? how long do they take to install?

SMOKIN01TA
04-16-2004, 01:04 PM
yeah thats why i shift at 5500 cuz i know the rpms are behind, the car doesnt get any faster past that so i just shift then, i definately want a shift light, where did you get yours and how much they run? how long do they take to install?
get a autometer for a tiny one or get the one for the defrost vent on the pillar. i have the autometer and it works great. i think you slowwww times are a combination of bad 60 fts and slow shifting/and wrong rpms. you just need lots of practice. it took me 25 passes before i figured out all the sweet spots in my old setup. now it rolls :D

hourang
04-16-2004, 01:53 PM
where can i get the shift light at? jegs? whats a good place to buy them?

SMOKIN01TA
04-16-2004, 02:17 PM
where can i get the shift light at? jegs? whats a good place to buy them?
which one. thunder sells the autometer and pill kits. i use it cause it works and its easy to adjust in a hurry, and its small and unnoticably for street racing

hourang
04-16-2004, 02:31 PM
what about the predator one? where can i get that one?

SMOKIN01TA
04-16-2004, 03:44 PM
what about the predator one? where can i get that one?
didnt know there was a predator, theres a raptor and a harlan

hourang
04-16-2004, 05:02 PM
didnt know there was a predator, theres a raptor and a harlan

never mind i meant the raptor, i found it now:)

SMOKIN01TA
04-16-2004, 05:24 PM
never mind i meant the raptor, i found it now:)
:judge: :jest: