View Full Version : Ramchargers Timing Tuner Failures...are these resolved?


verbs
04-13-2004, 08:24 PM
I've heard through the grapevine that some of the Ramchargers TT units have not worked as they were supposed to, one the cars who had this problem was Country Boy's..... Vince, didn't you have issues with yours too?

Something having to do with radio frequencies messing with the TT? Can anyone verify?

Just want to get the facts straight before I make any decisions on the TT.

383LQ4SS
04-13-2004, 09:10 PM
That was mine. It seemed to throw my timing out of whack. But I do not believe it to be the TT fault. I have ALOT of crank endplay and think I was getting a weak CPS signal due to the crank/reluctor walking away from the CPS. Routing it through the Timing Tuner just made it worse. However...when I wasnt having that problem....it worked well. I dynoed 707 rwhp with one. We used one on Vinces car and it worked very well...no problems at all.

Be sure to buy one with the updated window switch.

I think the problems some where having were mostly due to CPS signal problems and not directly due to the TT. And I know of two....me and Country Boy.

1a-play
04-13-2004, 11:00 PM
how do you know if it has the updated window switch?

VINCE
04-14-2004, 07:25 AM
No problems on my car. Al actually borrowed mine and still ended up with some kind of mysterious issue. I drove around with mine for months w/out any problems. I have over 20 mustang dyno pulls with mine and it never showed signs of having a problem.