Manual Transmission - Spacer that comes with Spec clutch?




Krab
07-31-2004, 02:10 PM
I'm having trouble with my car right now. I just installed a spec stage 3 clutch with updated hydraulics, new GM flywheel, and pilot bearing. I performed the drill mod on the master cylinder before installing it. My problem right now is that the car will not go into any gear while it is running (engine on, not car moving). It will go into any gear just fine with the key in the ignition, but nothing while the car is on. So basically, I can't drive my car off the rhino ramps it has been on since Monday afternoon (7/26/04). I've tried bleeding the system from the master cylinder hole with a mityvac, and get very few bubbles being sucked out. I also gravity bled by loosening the bleeder valve on the slave cylinder for a few hours. All this was done while the hydraulics were installed. During the install, I noticed that green colored spacer that comes with the spec clutch kit. I didn't think it made much difference, so I didn't even think twice about installing it.

I have been searching a lot since the clutch has been in (Thursday) and I came upon a thread that mentions the spacer is not needed on cars that got a new flywheel, it is only needed for those that machined their stocker (to compensate for the material taken off). Apparently, it will cause problems if it is installed on a car with a new flywheel (didn't specify what problems). So, is there any truth to this? Will taking off the spacer between the slave and the tranny remedy this problem I'm having? Sorry for the length, it's just that I'm anxious to start the break in period for the spec.


felton316
07-31-2004, 05:57 PM
The spacer is not your problem. I've been running the spacer and a new flywheel for quite some time now. It sounds like a hydraulics problem. Can you get someone to pump and hold the clutch while you bleed the slave?

jpz06
07-31-2004, 06:41 PM
I'm in the same boat right now, I posted a thread on having no presure but got no response, I guess no body knows. I'm going to try to bleed the slave cylinder again see if that helps.


Camaro00_SS
08-04-2004, 05:27 PM
So that's what the green felt covered spacer's for? Oh shiitttttttttttt............

Krab
08-06-2004, 12:34 AM
Thanks for the help guys, I found the problem and it wasn't the spacer. I'm just too embarassed to say what it is. :emb:

Clutch is working great now. :nod:

JackZ28
08-06-2004, 04:15 AM
It is a shim that allows for proper engagement/disengagement of the clutch! :)