View Full Version : Got some 93 ?'s


PurpleHaze98
04-08-2005, 09:21 AM
Hey I know this is an LS1 forum but i thought id ask anyways.
Were there any problems w/the 93 z-28 besides the lt1?
anybody know build numbers on the medium purple pearl metallic camaros?
Im looking at one the same color as our vette for $6700, its a auto Z-28 w/50k and its amazingly clean. Let me know what you guys think.
Thanks alot.
Tom

badjuju342
04-09-2005, 03:21 AM
I don't really know the build #'s on that car but the worst thing about LT1s is the Optispark ignition system . They're notorious for problems. If you have a good one , they're not bad but if you have a bad one ,DOH!http://www.ls1tech.com/forums/images/smilies/LS1Tech/gr_eek2.gif And tune-ups are NOT fun on those cars. '93 was the first year of the 4th gen but I've never heard of any horrible production bugs so I'm guessing you would be ok there.An LT1 is a definite improvement over the earlier TPI engines and can be brought up to stock LS1 performance with a few mods.

ACW
04-09-2005, 10:47 AM
http://www.camarosource.ca/php/camaro_info_db/index.php?act=colors_trim&year=1993 says Gray-Purple (Pearl) Metallic was on 4,920 Camaros in 1993. And http://www.camarosource.ca/php/camaro_info_db/index.php?act=colors_trim&year=1994 says 5,801 in 1994.

PurpleHaze98
04-09-2005, 10:52 PM
Thanks for the info guys. I might buy it im not sure, its just tooo clean to pass up.

87gnx
04-10-2005, 07:52 AM
Sounds like "good " miles for the year.With a couple of easy mods like a bigger throttle body, after market air filter and a "free flowing" exhaust(to start with) and you'll be set.

PurpleHaze98
04-11-2005, 09:04 AM
Yeah I was in a rush to maybe sell my truck but after i saw the production numbers i am in not so big of a hurry. Its a really clean car but im moving soon and im just prolly gonna buy an ls1 car. Already had one and want another.
Thanks for the answers

demonspeed
04-11-2005, 03:56 PM
ditto on the opti. Junk :barf: 95 they went to a vented design. Although better, it was still junk.

Also, 93 was the only year the 4th gen was speed density.