View Full Version : UMI LCA install


Shutout
10-02-2005, 10:01 AM
I installed UMI's tubular LCA's yesterday without to much trouble. It was pretty straightforward. Took the car out for a run, nailed it and all my wheelhop was gone . The car feels a little more solid also. My one complaint is the car seems to rattle more than before. Is this because the LCA's don't flex as much and is causing the car to rattle somewhere else?

nytmare1
10-02-2005, 03:00 PM
I installed UMI's poly and rod end LCAs and PHB this past Friday. I also noticed that they are a bit noisy. It's not bad by any means. I'm not getting any popping. Just a little rattling here and there. Mostly at lower speeds. I don't hear anything out of them at highway speeds. I double checked the torque on the bolts today and took them up to 90 ft/lbs. I guess the minor rattling noise is just the result when using rod ends. They're working great too!

Marc

joblo1978
10-04-2005, 09:43 PM
I installed UMI's poly and rod end LCAs and PHB this past Friday. I also noticed that they are a bit noisy. It's not bad by any means. I'm not getting any popping. Just a little rattling here and there. Mostly at lower speeds. I don't hear anything out of them at highway speeds. I double checked the torque on the bolts today and took them up to 90 ft/lbs. I guess the minor rattling noise is just the result when using rod ends. They're working great too!

Marc

You should hear poly/poly, heh. Sounds like someones gettin' busy on your spoiler. Squeak squeak sqeak squeak.

nytmare1
10-04-2005, 09:55 PM
You should hear poly/poly, heh. Sounds like someones gettin' busy on your spoiler. Squeak squeak sqeak squeak.

LOL... in that case, mine sound like old people gettin' busy.

95camaroz28
10-05-2005, 11:07 AM
I have wheel like like a mofo also. will just new lcas do the trick to get rid of it? how much where they and do you recommend anything else, this is on a 95 z