Stereo & Electronics - speaker help




View Full Version : speaker help


ckingcmaro
12-24-2005, 11:49 AM
Ok I have a 2001 SS Camaro, with the Monsoon Stereo System. All of my speakers are working, Except the mid speakers (beside the buckets in the back). There is no power getting to the speakers but both of the speakers are in good condition. I beleive it is the amp that has gone out or something. Could you guys give me your opinion, and a solution to the problem, I would really like to keep the monsoon sound system..

Thanks, Caleb


Rescue Ranger
12-25-2005, 02:03 PM
No power to the speakers at all?

hehe.. not to be condescending, but they're not faded out on the HU are they ;)

If it is the monsoon amp that is fried, there are used ones that pop up on the FS section and sometimes on eBay also.

Used sail panel speakers go for 50-60$ typically too used if for some reason it was the speakers.

Don B 02 Z28
12-25-2005, 02:24 PM
Good advice, Ranger...I just repl. all of the Monsoon 2 ohm speakers(mainly, due to one of the door spks. being blown) including, the 4in hatch spks., in my Z28. In favor of, a JBL 4 ohm(70w rms/270 peak) speaker system(uitilizing the Monsoon amp to some degree) to go w/ the Pioneer AM/FM/XM HU.

Soooooo, now the Monsoons are on the f/s block and I had no idea what they were worth.

Hey, can you tell me if, the rear seat speaker are ones w/ the double set of connectors or the single set of connections???

Thanks,
Don


ckingcmaro
12-25-2005, 07:09 PM
I think single?? (only 2 wires)