View Full Version : lights


04goatinmass
05-25-2006, 03:54 PM
today i noticed my fog lights r not working anymore.the switch inside lights up.any thoughts?

Captainofiron
05-25-2006, 05:52 PM
there is a relay in the box under the hood for the fogs, move them around and see if the light go back on, other than that check the switch inside, check if your lights are in low beam, and finally check the fog lights themselves and the harness going to them

y2k_ta
05-25-2006, 06:55 PM
Maybe the bulbs have both blown?

04goatinmass
05-25-2006, 08:00 PM
thanks guys.i bet i can take a dc volt meter and with the lights on see if i get anything.just weird im sure both bulbs didnt blow.those stock ones are pretty cheap.any thoughts on replacement without changing housings?

y2k_ta
05-26-2006, 12:09 AM
thanks guys.i bet i can take a dc volt meter and with the lights on see if i get anything.just weird im sure both bulbs didnt blow.those stock ones are pretty cheap.any thoughts on replacement without changing housings?

I've had both bulbs go out rather close together before, so I wouldn't totally rule that out. I've found that the Sylvania brand seems to last much longer as a replacement bulb for the stock lights. Whatever GM used didn't last very long at all.

04goatinmass
05-26-2006, 12:27 AM
i looked up the silverstar 893 .will those work.also is there a write up for removing those housings i wanna clean them up.

y2k_ta
05-26-2006, 07:24 AM
Here are the two driving light bulb brands that I've had the most success with on my 'bird. The Sylvania 880 & Napa 880.

http://www.ls1tech.com/forums/attachment.php?attachmentid=65752&stc=1