View Full Version : Magic Coolant???


speedfrk77
09-09-2006, 08:03 PM
Today I took my Z-28 to gets its oil changed. When the coolant was checked, they said that it was bone dry.
I had the car in for a check up this past month and it was full and good for -20 degrees. There was no coolant puddles under my car.

Has anyone else experienced this problem? Thoughts on what it could be?

BLKWS.6
09-09-2006, 08:39 PM
It COULD be a lying tech. Why dont you visually/physically verify this. When I took my 5.0 to MY OWN dealership that I worked for for a year (and was in good standing with at that time and currently) they lied to me BIG TIME "Sir, we found no codes on the OBDI scanner"

I went and payed ANOTHER $30 and got one myself...it pulled so many codes that I now have a carb.

2001NBMZ28
09-09-2006, 08:56 PM
Make sure it's topped off and check it yourself for a while. If the low coolant sensor is still plugged in should've thrown a low coolant light too.

RPM WS6
09-10-2006, 02:08 AM
Today I took my Z-28 to gets its oil changed. When the coolant was checked, they said that it was bone dry.

I find that hard to beleive. Perhaps they meant that the coolant overflow bottle was bone dry. No way in hell was the entire cooling system bone dry without you experiancing some serious overheating issues.

speedfrk77
09-11-2006, 10:37 PM
The overflow and my radiator were dry and my low collant light never went on. My temp was still between 200 and 210. I just can't see how it was that low

The Butcher
09-11-2006, 11:04 PM
Well, first things first. If your coolant was empty, were did it go? It's good for 7 years...it doesn't evaporate. Having worked at a dealership myself, I can follow with what Stanger88 is saying. I had guys that worked with me tell me ALL KINDS of b.s. stories, so I could imagine what they would say to someone they assume doesn't know as much as them. Some one just wanted to nickel and dime ya so they could get some extra $$$ from ya for coolant. Overflow bottles are pretty much just that. They can be empty, in fact every car I've ever built that was onna the first things to "get lost".

will350wax
09-12-2006, 01:23 AM
I had a very tiny leak in my 02 SS's radiatior. It never leaked on the ground but when it was hot it would "mist" out. Never made a puddle, but it got to where I would add a galon every other day. They could be jerking your chain or you might have a small leak.

blackfang
09-12-2006, 08:59 AM
Did you check it yourself?

charger01
09-12-2006, 12:43 PM
I'm sure it's fine.

speedfrk77
09-12-2006, 08:10 PM
I checked it the next day and both the overflow and the radiator were still full and there was no puddle. I am going to check it this weekend.

blackfang
09-13-2006, 10:32 AM
I have worked with some shady Techs though.