View Full Version : How hard can I leave on this setup?


TS6
10-08-2006, 11:11 AM
I ran a 10.42 at nearly 135 yesterday, but I left very soft (1.63 60') and didn't go WOT until late 2nd gear. It ran 105 mph in the 1/8. So I picked up 30 mph on the big end, which seems like alot but I suppose thats what happens when you don't give it full throttle the whole time. I am concerned about breaking the trans or rear end on launch. Its a Strange 12 bolt with a posi, I think 31 spline axles, etc. Pretty standard. The tranny is built but I know some guys have busted input shafts on them (4L60E). The kicker is the car is heavy, like 3800 lbs. with me in it. I have cut some 1.5x 60' times last year running mid 11's, and I think it will go 1.4x safely, I just need to know how to "limit" the launch power. Using my foot won't work to well.....

TwoFast4Lv
10-08-2006, 12:09 PM
I am coiming out of the hole on a 780RWTQ N2O spike. Not sure how long it will last so I started trailering in ;)

02SOMWS6
10-08-2006, 12:14 PM
I was launching at 6,700 rpm and cut 1.47 60ft.'s with a stick

Navy David SS
10-08-2006, 12:15 PM
You'll never know until you step it up. Moser's are usually very stout. 31 spline is a little small. What do you figure your HP is on launch? Do you have someone handy to tow you home :jest:

David

Pro Stock John
10-08-2006, 12:47 PM
I'm still running 31 spline 9 inch stuff, but I have 35 spline stuff ready to go in. I left off the transbrake cutting 1.35.

TS6
10-08-2006, 01:08 PM
Its a strange 12 bolt, can't remember if its 31 spline or 33. Gotta ask Billingsley.

I always trailer it, I'm too far to risk it. I just don't want to break it right now, spent a ton this year on it and would like to enjoy it some. I'd rather run mid 10's and have fun than run high 9's and be wrenching all the time.

TS6
10-08-2006, 01:10 PM
You'll never know until you step it up. Moser's are usually very stout. 31 spline is a little small. What do you figure your HP is on launch? Do you have someone handy to tow you home :jest:

David


I would guess I would be around 500 rwhp at launch if I really hit it. It comes up quick though.

Pro Stock John
10-08-2006, 01:12 PM
What tires out back? What psi? Drag shocks up front?

daniel6718
10-08-2006, 02:27 PM
i got 1.52 on a stock tenbolt...your 12 bolt should be fine...the tranny is all up to who built it i cant say

TS6
10-08-2006, 02:45 PM
What tires out back? What psi? Drag shocks up front?


325/50/15 MT DR's, 18 psi. QA1's all around. I guess I'm lucky, the car has always hooked at the track. It used to even hook on the street in 11 second trim.

01350ss
10-11-2006, 06:26 PM
I'd be causious. My 12 bolt snapped like a twig on launch. It was a strange 12 bolt posi and 33 spline axles w/4.30's. This was off the clutch at 5 grand on 27x9x15 slicks
The rear lasted 4 launches. It did do fairly well for the first 1400 street miles though.
By the way, this was with 370rwhp/365rwtq
Now I have a Moser 9" spool with 4.56 and 28x10x15 slicks and a lot more power.