View Full Version : Problem with lights


09CPTN
11-30-2006, 12:43 PM
Ok, here's the deal. I just had my passenger side turn signal bulb socket replaced cause it melted down. It worked fine for a while, but now the light wont stay on(running lights). Blinker works fine. I'm going to try just replacing the bulb and hope it was a bad filament. Also, my passenger side fog light was burned out, so I replaced the bulb. But now it's out again :bang: . I'm going to check the bulb to see if it's fried. If it's not i'll check the fuses. I fear a short for both of these problems though, which sucks cause I wont be able to fix that myself. Any thoughts?

09CPTN
11-30-2006, 02:16 PM
Changed turn signal bulb. Looks like one of the metal pieces on the bulb got fried. Hope that socket isn't bad too. If it is then it's prolly a short. Fog light bulb is fine. Tested it with the horn fuse(same fuse) fuse is fine, so I dunno why that's not working.

99camaroB4C
11-30-2006, 04:59 PM
Join the club, I had a park light that had the same melting problem. Now both of my blinkers dont work (the park lights work.) Also my headlights only come on when I turn the light switch on. I am as confused as you are. If I find out what my problems are I will report back to you, maybe it could help.

97LT1
12-01-2006, 08:37 AM
I am having light issues as well. I have been having problems with rear brake and turn signal sockets corroding. It seems the seals that seal out the water from the inside of the bulb assembly leak. I used a battery cleaner brush, and I coated with a good coat of dielectric grease.

I got my back brake light (right) working, but no luck with the blinkers yet. Gonna check all fuses today.