View Full Version : vette problem?


427TTA4
02-05-2007, 05:31 PM
Its a 99 86k miles C5 no mods 6spd.I was on the interstate and down shifted from 5th to 4th I heard a snap from under the shifter.the car stop moving and the pedal got stuck to the floor the gears go in without having to press the pedal but goes no where.Anything you do is as if its allways in nuetral Random of people recomended it was the clutch slave so I replaced the clutch,pressure plate, and slave.So we did when it was done it was up in jack stands I put the wheels on I started the car,pressed the pedal,shifted to first, and like if I was in a light I slowly removed the clutch pedal and the wheels moved in the air so I droped it to the ground and nothing happed like as if we didnt even touched the car same symthoms remain.Someone please help in fustrated especially when my 35 year old uncle comes over to my house with his dumb stock but only has a muffler loud as hell rx8 and keeps talking his smack about he will race me and give me 20 cars in the 1/4 mile and he will still pass me and I say no way but he keep on telling me cuz his car will move and not mine and laughs that gets me angry.Thanks for looking

EPP
02-05-2007, 06:08 PM
We recently had this problem with a Caddy CTS-V, and it turned out to be the master cylinder. It did the exact same thing as what you are describing. Bob

427TTA4
02-05-2007, 07:03 PM
Your talking about the clutch master cylinder right just wanna make sure.

Zturd
02-05-2007, 08:10 PM
This is just a dumb question but it almost sounds like the rod from your shifter to the trans is not moving. Could you lift up the shifter boot or take it off and shift the gears and have a friend look up through and make sure its moving the gears in the trans? Put the car back up and while its ups have someone grab ahold of the rear wheels and turn them engaging and disengaging the clutch and shifting to see if tension or anything unsmooth is felt. Hope this helps

BlownVette 2001
02-05-2007, 11:33 PM
It's obvious that you are not getting any power to the rear wheels.

Can you put the car into gear and still push it while its parked, if so you have something broke in the drive line.

You'll need to drop everything and check it out.

Torque tube - grab each side and make sure it spins the other side.

Tranny - Put in gear and make sure it spins the main shaft.

Sounds to me like you broke something, also check the rear.

LS1LT1
02-05-2007, 11:40 PM
Torque tube - grab each side and make sure it spins the other side.Yeah could be the torque tube internals, sometimes in ultra high mileage and/or high power/racing situations a torque tube bearing can sieze up.

EPP
02-06-2007, 05:20 AM
Your talking about the clutch master cylinder right just wanna make sure.

Yes, I was indeed talking about the clutch master cylinder. Your "pedal got stuck to the floor the gears go in without having to press the pedal but goes no where" description is the same problem we had. Bob