View Full Version : Turn signals quit working completely


BigRedZag
03-20-2007, 04:01 PM
Searched and found the question before but after checking the bulbs (fine) and fuse (fine) I'm at a loss as to why I have no turn signals at all. Just took the car out of storage and I'm not sure if they worked at first or not as I didn't notice until an hour of so of driving that they weren't working. Any suggestions?

WS6 Rampage
03-20-2007, 04:07 PM
lol,....My best friend and I where talking about this exact same thing happening to him. I took a look at it and I couldn't figure the damn thing out.

SmallblockV8LS1
03-20-2007, 04:14 PM
could be the stalk? i had that happen to me in an Integra once...just an i dea

beast69camaro
03-20-2007, 04:47 PM
turn signal switch.....it's in the column and kind of a pain in the ass to change. Mine went out a while back, 2 tickets later and I finally decided to change mine last weekend. It's about $32 from autozone and requires a steering wheel puller and lockplate remover, both of which are also available for rent from autozone.

beast69camaro
03-20-2007, 04:48 PM
or on second thought, and a cheaper fix...would be to replace the flasher (thing that makes the bulbs flash, located under the driver's side dash). Try that first.

WS6 Rampage
03-20-2007, 05:04 PM
or on second thought, and a cheaper fix...would be to replace the flasher (thing that makes the bulbs flash, located under the driver's side dash). Try that first.
What does it look like?

BigRedZag
03-21-2007, 10:31 AM
My 4 way hazards still work, would they do that with the flasher out??

Candyredz28
03-21-2007, 10:41 AM
I got the same problems, my hazards work but not my turn signals, I also replaced the flasher and one of the turn signals worked but there was no light at all for the other turn signal so most likely is the turn signal indicator.

VIP1
03-21-2007, 03:44 PM
There are two flashers.
One is for the left/right signals,
The other one is for the hazards.

If one side works and the other doesnt, then there is nothing wrong with the flasher.

Turn on the hazards and look for the bulb that either isnt flashing, flashing erratically, or not lit at all. That will be the culprit. The front and rear turnsignals are dual filament. The dim fiament is for the "parking" lights and the brighter filament is for brake lights and signals.

Once you've found the offending bulb inspect its socket. Either the socket has corroded or the bulb has blown.

If all the above are in working order and both left/right signals still don't work, then it could be the switch in the stalk.

WS6 Rampage
03-21-2007, 03:52 PM
Nice,.. I'll do it today on my boys car and i'll let you all know what happens.

onebadbird96
03-21-2007, 04:02 PM
I got the same problem kinda my blinker works some times and some times it dont what could that be