View Full Version : Loud Noises when I accelerate and turn???


Benny Blanco
03-24-2008, 05:26 PM
So i noticed this last week and its finally outta control. It started off with a mild clunk and now its really loud I was racing last nite and I did a burn out and it got much worse so when I launched it made a huge clunk but I was able to still drive it home it makes the noise when I speed up from a deadstop and when I make left or right turns I have a BMR torque so I know its not that can anybody trouble shoot this problem for me Thanks fellas......BB

sevenstarsfall
03-24-2008, 05:38 PM
Sounds like you broke the spider gears in the differential.....

DarkJuggalo
03-24-2008, 05:41 PM
does it sound like a loud banging? mine was makin noises like this but banging from a dead stop. was a bad tranny mount

sevenstarsfall
03-24-2008, 05:45 PM
He said that it makes it under hard acceleration and turns so it could be a combo of the mount and the gears.

Id check the mount which could cause the banging under acceleration and pull the rear cover to check the gears.

Benny Blanco
03-24-2008, 05:57 PM
damn and I just did the gasket and fluid change last week...this sucks ..BB

sevenstarsfall
03-24-2008, 06:10 PM
Yeah, that would suck....let us know what you find

Benny Blanco
03-24-2008, 06:13 PM
I will!!! good lookn out bro.....be koo....BB

goinfast
03-25-2008, 07:59 PM
i have the same prob no idea whats goin on i just changed my fluid too and it seem to get worse

Benny Blanco
03-26-2008, 12:26 AM
welcome to the club hahahaha This is the second time I changed the gasket and fluid out and its gona happen again this shit isnt cheap man its time to recycle my fluid again....Iam gona get a moser 12 bolt with 373 for 1000 bucks and it only has 200 miles on it fuck this 10 bolt bs its time to HOOK UP.

Benny Blanco
03-27-2008, 06:27 PM
totally blown oh well My Moser is coming in a few days woo hoo can you say HOOKED UP.....BB