View Full Version : Any stick guys with a 12 bolt in here?


02SOMWS6
07-30-2008, 05:28 PM
I just blew my street gears apart on a 10.5 pass on a 100 shot. Before I switch to a set of pro gears and hit it with a 150-175 shot I figure I would check to see whats holding up or are pro gears the only option

CuNfUzEd
07-31-2008, 06:54 PM
Strange 410's here. No issues. Power and mods in my sig.

BAKED
08-01-2008, 12:21 PM
I've seen a few F body guys break their 12 bolts at our local track. Mostly heavier 6 speed cars making 450+ trying to launch hard.

BTW Your car is really clean and nice, props for not being afraid to beat the shit out of it. (Saw it in GM HTP)

GTFORMULA
08-03-2008, 07:40 PM
I had Moser street gears in mine and went 9.7 @ 144 only broke the spider gears.

02SOMWS6
08-04-2008, 10:40 AM
I've seen a few F body guys break their 12 bolts at our local track. Mostly heavier 6 speed cars making 450+ trying to launch hard.

BTW Your car is really clean and nice, props for not being afraid to beat the shit out of it. (Saw it in GM HTP)


Thanks, I put a spool in it never thinking I would blow the ring and pinion apart. That gear set had about 20 hard nos launches and pop. The thing that sucks is it broke at pinks all out. Friday car ran o.k. went 10.5 at 130. I was going to up my shot but not sure how much I would pick up with another 50hp so I left it alone. Sat. on the first pass boom my day was over.Now I have to switch to a set of pro gears which are track only gears unless I feel like throwing money away every 20 passes. I might just start looking for a back up rear

http://photosbyjim.smugmug.com/gallery/5481236_Bkg7e#335199011_ApYpD-L-LB

http://photosbyjim.smugmug.com/gallery/5481236_Bkg7e#335206587_2tnb6-L-LB

http://photosbyjim.smugmug.com/gallery/5481236_Bkg7e#335198484_pbtXJ-L-LB
there's more shots on Englishtowns web site if you click on photo shop

Formulized94
08-04-2008, 02:17 PM
Thanks, I put a spool in it never thinking I would blow the ring and pinion apart. That gear set had about 20 hard nos launches and pop. The thing that sucks is it broke at pinks all out. Friday car ran o.k. went 10.5 at 130. I was going to up my shot but not sure how much I would pick up with another 50hp so I left it alone. Sat. on the first pass boom my day was over.Now I have to switch to a set of pro gears which are track only gears unless I feel like throwing money away every 20 passes. I might just start looking for a back up rear

http://photosbyjim.smugmug.com/gallery/5481236_Bkg7e#335199011_ApYpD-L-LB

http://photosbyjim.smugmug.com/gallery/5481236_Bkg7e#335206587_2tnb6-L-LB

http://photosbyjim.smugmug.com/gallery/5481236_Bkg7e#335198484_pbtXJ-L-LB
there's more shots on Englishtowns web site if you click on photo shop


What tires are you on?

02SOMWS6
08-04-2008, 02:46 PM
What tires are you on?

MT Drag ET/28/10.5/15

TT632
08-08-2008, 10:25 AM
No problems with the torque armed 12 Moser in my 3rd gen with trans brake. The launches were kind of soft at less then 4000 rpm, 1.41-1.43

smokeum99ta
08-11-2008, 05:47 PM
This thread sounds so fimilar to what happened to me. After breaking 4-5 10bolts trying to get into the 11's I upgraded to the 12bolt. It worked fine until I started reaching the 10's. First time I broke the posi unit, second time twisted an axle (33 spline), third time broke r&p. So I had enough of it, pulled it, fixed it and sold it. Then bought a 9inch and have yet to hurt it. All of that breakage was pretty much at full weight thought. Now i'm much lighter but also much faster. Hope this helps.