ADD OIL Light - LS1TECH

Log In 


LS4 Performance Grand Prix GXP | Monte Carlo SS | Impala SS | LaCrosse Super

ADD OIL Light

Reply
 
Thread Tools Search this Thread
Old 12-30-2009, 10:53 PM   #1
On The Tree
Thread Starter
iTrader: (1)
 
hurley_21_07's Avatar
 
Join Date: Jul 2005
Location: Hurley, WI
Posts: 199
Default ADD OIL Light

At what point does that come on? It came on for me about a month or so ago, a month after I bought it. How low is the oil when that comes up?

Dan
hurley_21_07 is offline   Reply With Quote
Old 12-30-2009, 11:35 PM   #2
TECH Addict
iTrader: (5)
 
94ss06gxp's Avatar
 
Join Date: Aug 2009
Location: Mid MI
Posts: 2,351
Default

it usually comes on when its pretty low. any signs of leakage? if it does it again make sure to check it and check for any leaks.
94ss06gxp is offline   Reply With Quote
Old 12-31-2009, 12:30 AM   #3
TECH Enthusiast
iTrader: (2)
 
TiredGXP's Avatar
 
Join Date: Dec 2007
Location: Sherwood Park, AB
Posts: 677
Default

figure on it being about two liters low - pretty much off the end of the dipstick for the light to come on.
TiredGXP is offline   Reply With Quote
Old 12-31-2009, 11:10 AM   #4
TECH Addict
iTrader: (5)
 
AlabamaGuy's Avatar
 
Join Date: Jun 2009
Posts: 2,802
Default

Mine eats through Mobil 1 Syn. I hear about this on other LS engines as well. Don't ask me why.
AlabamaGuy is offline   Reply With Quote
Old 12-31-2009, 11:46 AM   #5
TECH Enthusiast
iTrader: (2)
 
TiredGXP's Avatar
 
Join Date: Dec 2007
Location: Sherwood Park, AB
Posts: 677
Default

My oil consumption is sitting at 1 liter every 5000km. Not too bad for 95,000km

TiredGXP is offline   Reply With Quote
Old 12-31-2009, 12:55 PM   #6
Staging Lane
iTrader: (1)
 
Join Date: Oct 2008
Location: Brooklyn, NY
Posts: 81
Default

mine was actually off the dipstick and I still did not get the light.
keviiinn is offline   Reply With Quote
Old 12-31-2009, 04:13 PM   #7
Launching!
iTrader: (2)
 
Tappeter's Avatar
 
Join Date: Mar 2009
Location: Central NY State
Posts: 257
Default

LS engines use small, low tension piston rings to reduce friction, increase power and fuel economy. Therefor, they use oil! Its a common weel known and accepted fact. Probably will use more synthetic oil then conventional oil since synthetic flows better/easier. Anyway, keep an eye on your oil levels. Mine has gone down over 2 quarts before oil light came on!
Tappeter is offline   Reply With Quote
Old 12-31-2009, 04:59 PM   #8
TECH Enthusiast
iTrader: (4)
 
Nick_Nasty's_GXP's Avatar
 
Join Date: Dec 2009
Location: Buffalo NY
Posts: 725
Default

Mine comes on when I am at 50% oil life
Nick_Nasty's_GXP is offline   Reply With Quote
Old 12-31-2009, 05:34 PM   #9
TECH Junkie
iTrader: (4)
 
Nacho SS's Avatar
 
Join Date: Feb 2007
Location: 805-818
Posts: 3,561
Default

I eat oil...and at $15/quart for my preferred Motul, that really chaps my ***.
Nacho SS is offline   Reply With Quote
Old 12-31-2009, 07:34 PM   #10
TECH Fanatic
 
Join Date: Jul 2007
Location: Reading, Pennsylvania
Posts: 1,115
Default

I had it come on twice in the 2 years I had my SS. Both times I needed to add a quart or less. This was on 5k mile interval oil changes with Mobil1. LSx engines tend to go through some oil as mentioned.
20SS07 is offline   Reply With Quote
Old 12-31-2009, 09:29 PM   #11
TECH Junkie
iTrader: (1)
 
Mels SS's Avatar
 
Join Date: Jun 2007
Location: New Orleans La
Posts: 3,159
Default

I haven't had that problem.
Mels SS is offline   Reply With Quote
Old 01-01-2010, 09:51 AM   #12
LS1Tech Platinum Sponsor
 
06MonteSS's Avatar
 
Join Date: Dec 2005
Location: CT
Posts: 2,865
Default

wow... have never used/burned oil in mine... level remains constant between my 6000 mile oil changes with Mobil 1.... and I'm at just about 83,000 miles on the car...
06MonteSS is offline   Reply With Quote
Old 01-01-2010, 11:31 AM   #13
TECH Addict
iTrader: (5)
 
AlabamaGuy's Avatar
 
Join Date: Jun 2009
Posts: 2,802
Default

Quote:
Originally Posted by Mels SS View Post
I haven't had that problem.
You're probably not done with your break in oil yet, Mel!
AlabamaGuy is offline   Reply With Quote
Old 01-01-2010, 01:34 PM   #14
Launching!
iTrader: (2)
 
Join Date: May 2009
Location: Long Beach CA.
Posts: 241
Default

after my last oil change the message popd up 2 times, the first time it popd up was about 2/3s oil life remaining, i said **** it and put a whole quart of royal purple... im due for an oil change right now, christmas day was the day i was supposed to get my next change but ive been broke, getting it changed next week for sure, this last week though the mesage came on again cudnt find rp in stock anywere so i got mobil one full synthetic, put half a quart this time in hopes to keep some oil so next change wen i run out again lol

this thing eats oil like crazy but i do have a lead foot.. every change i buy about 7 or 8 quarts of royal purple :/ this season has been bad on me though pokets is emptyyy
SSGoat is offline   Reply With Quote
Old 01-03-2010, 08:15 PM   #15
TECH Fanatic
iTrader: (2)
 
Join Date: Feb 2009
Location: Killeen, Texas.
Posts: 1,398
Default

Quote:
Originally Posted by Mels SS View Post
I haven't had that problem.
You have to drive the car in order to have it eat oil lol
CenTexSS is offline   Reply With Quote
Old 01-03-2010, 08:19 PM   #16
TECH Addict
iTrader: (5)
 
AlabamaGuy's Avatar
 
Join Date: Jun 2009
Posts: 2,802
Default

Quote:
Originally Posted by CenTexSS View Post
You have to drive the car in order to have it eat oil lol
Thank you! Someone else caught that.
AlabamaGuy is offline   Reply With Quote
Old 01-03-2010, 09:35 PM   #17
Launching!
 
98GTcoupe's Avatar
 
Join Date: Jun 2009
Location: Hurlburt FLD, FL
Posts: 223
Default

I run Royal Purple 5W-30 full synt and have never used any.....
98GTcoupe is offline   Reply With Quote
Old 02-07-2010, 09:29 PM   #18
Teching In
 
TTA1401's Avatar
 
Join Date: Aug 2005
Location: Washington DC
Posts: 5
Default

I have the same problem. '06 GP GXP with only 25K miles. Found this when I was searching on the net.

http://www.aera.org/ep/techbulletins/Q1-2009/TB2505.pdf

Doesn't sound good. I am going to take mine in.
TTA1401 is offline   Reply With Quote
Old 02-08-2010, 01:04 PM   #19
TECH Fanatic
iTrader: (3)
 
GXP25's Avatar
 
Join Date: Aug 2009
Location: Orlando, FL
Posts: 1,394
Default

Quote:
Originally Posted by TTA1401 View Post
I have the same problem. '06 GP GXP with only 25K miles. Found this when I was searching on the net.

http://www.aera.org/ep/techbulletins/Q1-2009/TB2505.pdf

Doesn't sound good. I am going to take mine in.
That is VERY interesting.

Thank you very much! I am currently working with on dealership on my engine oil usage.

I've been going in 1k and 1.5k intervals and they agree it's been running low but "we're still going to monitor it."
GXP25 is offline   Reply With Quote
Old 02-08-2010, 09:09 PM   #20
TECH Enthusiast
iTrader: (2)
 
smokin06impala ss's Avatar
 
Join Date: May 2009
Location: Mission,Tx
Posts: 733
Default

Quote:
Originally Posted by nick_nasty's_gxp View Post
mine comes on when i am at 50% oil life
^^^^x2
smokin06impala ss is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Metal Chunks found on oil drain plug Ls1AR New LS1 Owners - Newbie Tech 18 04-14-2013 02:44 PM
Transmission shop in Corpus Christi??? conde'strans Texas Members 9 05-21-2011 07:07 AM
Oil Change Interval on Infrequently Driven Cars slayer_taunu General Maintenance & Repairs 19 01-15-2010 10:15 AM
Car leaking oil fast, need help!! 00CaliforniaZ28 Generation III Internal Engine 16 01-02-2004 07:28 PM
Coolant smell under hood? GPowrie Generation III Internal Engine 8 07-27-2002 05:36 PM


Tags
2007, 428, add, carlo, caterpillar, chevy, consumption, full, grand, light, monte, motor, oil, pontiac, prix

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 03:48 PM.