Engine Light Problems After Replacing Cat - LS1TECH

Log In 


LS4 Performance Grand Prix GXP | Monte Carlo SS | Impala SS | LaCrosse Super

Engine Light Problems After Replacing Cat

Reply
 
Thread Tools Search this Thread
Old 06-18-2010, 10:05 PM   #1
Teching In
Thread Starter
 
GXP303's Avatar
 
Join Date: May 2010
Posts: 45
Default Engine Light Problems After Replacing Cat

Hello. New to the board. I own a 2008 Grand Prix GXP. I just replaced my exhaust system with a magnaflow catback system. I also replaced the cat with a high-flow cat. My engine light is turning on and I can no longer use my remote start feature. Should I put the stock cat back on? I Know these next comments sound crazy but it happened so here goes nothing. The other day I was parked off to the side of the road while on a phone call and abruptly It sounded and felt like someone hit my car. It jolted like it was hit. Any clue? Any help would be much appreciated. Thanks.
GXP303 is offline   Reply With Quote
Old 06-18-2010, 11:01 PM   #2
TECH Fanatic
iTrader: (4)
 
monte_with_a_LS4's Avatar
 
Join Date: Mar 2010
Location: Springfield, IL
Posts: 1,124
Default

Quote:
Originally Posted by GXP303 View Post
Hello. New to the board. I own a 2008 Grand Prix GXP. I just replaced my exhaust system with a magnaflow catback system. I also replaced the cat with a high-flow cat. My engine light is turning on and I can no longer use my remote start feature. Should I put the stock cat back on? I Know these next comments sound crazy but it happened so here goes nothing. The other day I was parked off to the side of the road while on a phone call and abruptly It sounded and felt like someone hit my car. It jolted like it was hit. Any clue? Any help would be much appreciated. Thanks.
welcome! getting it tuned will take care of the CEL and was it the wind from cars passing you while u were sitting still maybe lol

Last edited by monte_with_a_LS4; 06-18-2010 at 11:13 PM.
monte_with_a_LS4 is offline   Reply With Quote
Old 06-18-2010, 11:31 PM   #3
Staging Lane
iTrader: (1)
 
Join Date: Jun 2009
Posts: 52
Default

I have the high flow cat with a 3 inch down pipe and I do not get a light because I have done the O2 sensor mod
http://www.energeticforum.com/renewa...n-foulers.html
smug_GXP is offline   Reply With Quote
Old 06-19-2010, 12:43 AM   #4
TECH Fanatic
iTrader: (5)
 
williamGT's Avatar
 
Join Date: Jul 2008
Location: Yellowknife NT Canada
Posts: 1,467
Default

Welcome you got a PM that i replied to you message.
williamGT is offline   Reply With Quote
Old 06-19-2010, 07:30 AM   #5
TECH Enthusiast
 
Count of Monte Carlo's Avatar
 
Join Date: Apr 2007
Location: Albany, NY and NePA PENNA
Posts: 697
Default

The stainless steel O2 sensor extension does work. I havent had a light in 2.5 months. Nice to know I can stil use the down pipe.
Count of Monte Carlo is offline   Reply With Quote
Old 06-19-2010, 01:50 PM   #6
TECH Resident
iTrader: (1)
 
Join Date: May 2008
Location: Ontario, Canada
Posts: 763
Default

just get it tuned out. i ditched the cat and have had the light on for awhile now since i havn't been able to get to my tunner and my A/F ratio is still in check so i wouldn't worry.
StealthV8 is offline   Reply With Quote
Old 06-20-2010, 02:02 AM   #7
Teching In
Thread Starter
 
GXP303's Avatar
 
Join Date: May 2010
Posts: 45
Default

Thank You for the replies and suggestions. Very Helpful.
GXP303 is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
GXP Cat/Resonator Bolts GXP06IL LS4 Performance 0 10-20-2015 12:20 AM
gxp exhaust help! TISmyBOOMSTICK LS4 Performance 33 07-13-2015 05:58 PM
Magnaflow vs. stock gxp exhaust 06gpgxp LS4 Performance 12 12-15-2011 02:30 AM
Is a Downpipe Worthwhile w/o and exhaust? turbotaguy LS4 Performance 39 03-29-2009 06:42 PM
Tech Bulletin for 2005 GXP with water sound in dash when cold... dj_stylzpgh/GXP05 LS4 Performance 4 03-23-2008 04:01 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 09:25 AM.