Go Back   LS1TECH > VEHICLE SPECIFIC FORUMS > LS4 Performance
Sign in using an external account
Register Forgot Password?
Search

LS4 Performance Grand Prix GXP | Monte Carlo SS | Impala SS | LaCrosse Super

Engine Light Problems After Replacing Cat

Reply
 
Thread Tools Search this Thread
Old 06-18-2010, 10:05 PM   #1
Teching In
 
GXP303's Avatar
 
Trader Rating: 0
Join Date: May 2010
Posts: 45
Default Engine Light Problems After Replacing Cat

Hello. New to the board. I own a 2008 Grand Prix GXP. I just replaced my exhaust system with a magnaflow catback system. I also replaced the cat with a high-flow cat. My engine light is turning on and I can no longer use my remote start feature. Should I put the stock cat back on? I Know these next comments sound crazy but it happened so here goes nothing. The other day I was parked off to the side of the road while on a phone call and abruptly It sounded and felt like someone hit my car. It jolted like it was hit. Any clue? Any help would be much appreciated. Thanks.
GXP303 is offline   Reply With Quote
Old 06-18-2010, 11:01 PM   #2
TECH Fanatic
 
monte_with_a_LS4's Avatar
 
Trader Rating: 4
Join Date: Mar 2010
Location: Springfield, IL
Posts: 1,124
Default

Quote:
Originally Posted by GXP303 View Post
Hello. New to the board. I own a 2008 Grand Prix GXP. I just replaced my exhaust system with a magnaflow catback system. I also replaced the cat with a high-flow cat. My engine light is turning on and I can no longer use my remote start feature. Should I put the stock cat back on? I Know these next comments sound crazy but it happened so here goes nothing. The other day I was parked off to the side of the road while on a phone call and abruptly It sounded and felt like someone hit my car. It jolted like it was hit. Any clue? Any help would be much appreciated. Thanks.
welcome! getting it tuned will take care of the CEL and was it the wind from cars passing you while u were sitting still maybe lol
__________________

07 TBSS AWD- 418 Forged Stroker l Nitto 420s l AR Headers l RPM Stg 6 Trans l KW Coilovers l PCM CA Il Yank 2800
SOLD-06 Monte SS-20" ADRs on Dunlop Direzza DZ10s Front: 255/35/R20 Rear: 245/35/R20 l Doug Thorley Headers l Custom exhaust- res and cat delete l K&N CAI l SSC Lowering Springs l Don Rome STB Bars l DiabLew Tuned l Thrasher Shift Kit l Poly Motor mount and Dogbone l Tranny Cooler l Tranny Temp Gauge |

Last edited by monte_with_a_LS4; 06-18-2010 at 11:13 PM..
monte_with_a_LS4 is offline   Reply With Quote
Old 06-18-2010, 11:31 PM   #3
Staging Lane
 
Trader Rating: 1
Join Date: Jun 2009
Posts: 52
Default

I have the high flow cat with a 3 inch down pipe and I do not get a light because I have done the O2 sensor mod
http://www.energeticforum.com/renewa...n-foulers.html
__________________
06 Grand Prix GXP
Stock Crawlin Junk
smug_GXP is offline   Reply With Quote
Old 06-19-2010, 12:43 AM   #4
TECH Fanatic
 
williamGT's Avatar
 
Trader Rating: 5
Join Date: Jul 2008
Location: Yellowknife NT Canada
Posts: 1,467
Send a message via MSN to williamGT
Default

Welcome you got a PM that i replied to you message.
__________________
Summer car: Paid off on June 2014
2009 Pontiac G8 GT Panther metallic black, Onyx/Red interior. DT shorty headers, Catless, Solo Mach cat-back, sport metallic pedals, Roto-Fab intake, Powerbond underdrive pulley, GXP front bumper, GXP rear diffuser, Roto-Fab rad cover, Holden 6.0 V8 badges, Oil Pressure, Oil Temp and Battery gauges on center dash (Atari style) and DOD de-activated.

williamGT is offline   Reply With Quote
Old 06-19-2010, 07:30 AM   #5
TECH Enthusiast
 
Count of Monte Carlo's Avatar
 
Trader Rating: 0
Join Date: Apr 2007
Location: Albany, NY and NePA PENNA
Posts: 697
Send a message via AIM to Count of Monte Carlo
Default

The stainless steel O2 sensor extension does work. I havent had a light in 2.5 months. Nice to know I can stil use the down pipe.
__________________
Lorenzo

'10 DODGE Challenger R/ T Classic 57M6 "Blue Whale"

'92 PONTIAC Grand Prix SE 34M5 "Red Lobster"
Count of Monte Carlo is offline   Reply With Quote
Old 06-19-2010, 01:50 PM   #6
TECH Resident
 
Trader Rating: 1
Join Date: May 2008
Location: Ontario, Canada
Posts: 763
Default

just get it tuned out. i ditched the cat and have had the light on for awhile now since i havn't been able to get to my tunner and my A/F ratio is still in check so i wouldn't worry.
__________________
Looks stock eh
StealthV8 is offline   Reply With Quote
Old 06-20-2010, 02:02 AM   #7
Teching In
 
GXP303's Avatar
 
Trader Rating: 0
Join Date: May 2010
Posts: 45
Default

Thank You for the replies and suggestions. Very Helpful.
GXP303 is offline   Reply With Quote
Old 06-20-2010, 02:02 AM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 03:50 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details