Go Back   LS1TECH > VEHICLE SPECIFIC FORUMS > LS4 Performance
Sign in using an external account
Register Forgot Password?
Search

LS4 Performance Grand Prix GXP | Monte Carlo SS | Impala SS | LaCrosse Super

Welcome to LS1Tech.com!
Welcome to LS1Tech.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join LS1Tech.com today!


Reply
 
Thread Tools Search this Thread
Old 07-25-2012, 09:01 AM   #1
On The Tree
Garage is empty, add now
 
Trader Rating: 0
Join Date: Sep 2011
Posts: 113
Default abs light help

Had abs traction control break light steering assist light and steering light came on scanned car got a b0550 a b0896 b0898 says ecm ecm voltage . i looked at ecm appears fine anyone else ever experience this?
PurpleHaze9414 is offline   Reply With Quote
Old 07-25-2012, 09:25 AM   #2
On The Tree
2006 Pontiac Grand Prix
 
Trader Rating: 0
Join Date: Oct 2011
Posts: 170
Default

I believe a failing hub/abs sensor could cause this. How many miles on the front bearings/hubs?
The_Madcat is offline   Reply With Quote
Old 07-25-2012, 11:05 AM   #3
Teching In
Garage is empty, add now
 
Trader Rating: 0
Join Date: Dec 2011
Location: MICHIGAN
Posts: 34
Default

I have all the same lights on, Mine ended up being the whole ABS module. It had low output voltage coming out of the ABS module.
WMCC NICK is offline   Reply With Quote
Old 07-25-2012, 06:41 PM   #4
On The Tree
Garage is empty, add now
 
Trader Rating: 0
Join Date: Sep 2011
Posts: 113
Default

I bet its abs module it says low voltage how much did that cost u?
PurpleHaze9414 is offline   Reply With Quote
Old 07-25-2012, 09:31 PM   #5
Teching In
Garage is empty, add now
 
Trader Rating: 0
Join Date: Dec 2011
Location: MICHIGAN
Posts: 34
Default

The couple I found where $500+ for new, I might go the used route, its half the $ and from what I hear its not a common problem, so hopefully it will last. But still not sure, which way to go.
WMCC NICK is offline   Reply With Quote
Old 07-27-2012, 03:15 PM   #6
TECH Fanatic
2007 Chevrolet Monte Carlo
My Garage
 
neilownz's Avatar
 
Trader Rating: 0
Join Date: May 2008
Location: Fargo, ND
Posts: 1,767
Default

ABS fixer might fix them. I know on my truck you can run without the module, but the light stays on or something.
neilownz is offline   Reply With Quote
Old 08-02-2012, 09:59 AM   #7
On The Tree
Garage is empty, add now
 
Trader Rating: 0
Join Date: Sep 2011
Posts: 113
Default

Has anyone had there abs traction break and variable effort steering light go off bc of low break pads?
PurpleHaze9414 is offline   Reply With Quote
Old 08-02-2012, 09:59 AM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply

Tags
1998, abs, b0896, b0898, camaro, carlo, grand, gxp, light, location, ls1, module, monte, pontiac, stays


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 06:49 PM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - JOBS
Emails & Contact Details