Getting occasional backfiring... - LS1TECH

Log In 


LT1-LT4 Modifications 1993-97 Gen II Small Block V8

Getting occasional backfiring...

Reply
 
Thread Tools Search this Thread
Old 02-20-2010, 08:51 AM   #1
Launching!
Thread Starter
 
xxRONNIExx's Avatar
 
Join Date: Jun 2009
Posts: 247
Default Getting occasional backfiring...

Ok usually when I hit the gas hard in idle or if Im on the freeway and let off the gas I get a loud backfire. Not sure what the cause is. I did recently get LT headers put on so Im wondering if I may need a tune? ALso deleted the EGR and AIR. Plugs and Wire have less than 1000 miles on them...
xxRONNIExx is offline   Reply With Quote
Old 02-20-2010, 08:59 AM   #2
TECH Fanatic
iTrader: (2)
 
draggin97s10's Avatar
 
Join Date: Mar 2009
Posts: 1,471
Default

its unburned gas in the pipes. running rich because of the lts it will prolly fix itself keep driving it
draggin97s10 is offline   Reply With Quote
Old 02-20-2010, 09:21 AM   #3
Launching!
Thread Starter
 
xxRONNIExx's Avatar
 
Join Date: Jun 2009
Posts: 247
Default

Quote:
Originally Posted by draggin97s10 View Post
its unburned gas in the pipes. running rich because of the lts it will prolly fix itself keep driving it
Even after about 2 weeks now?
xxRONNIExx is offline   Reply With Quote
Old 02-20-2010, 09:44 AM   #4
TECH Fanatic
iTrader: (2)
 
draggin97s10's Avatar
 
Join Date: Mar 2009
Posts: 1,471
Default

**** shouldnt be. codes?
draggin97s10 is offline   Reply With Quote
Old 02-20-2010, 09:52 AM   #5
Launching!
Thread Starter
 
xxRONNIExx's Avatar
 
Join Date: Jun 2009
Posts: 247
Default

No I don't have any codes. Haven't taking it to a shop yet for a diagnostic. It ran fine before the headers now its runs somewhat rough and backfires.
xxRONNIExx is offline   Reply With Quote
Old 02-20-2010, 09:54 AM   #6
TECH Fanatic
iTrader: (2)
 
draggin97s10's Avatar
 
Join Date: Mar 2009
Posts: 1,471
Default

how did you extend the o2s
draggin97s10 is offline   Reply With Quote
Old 02-20-2010, 10:03 AM   #7
12 Second Club
iTrader: (7)
 
NAVY99B4C's Avatar
 
Join Date: May 2009
Location: Walton, Indiana
Posts: 277
Default

I had the same problem with my LT car after full exhaust. never could find the problem. mine backfied all the time. i changed plugs and wires and rerouted my wires so there were away from the headers and it hasnt done it since. I think the heat broke down my wires really fast.

Id say a tune wouldnt hurt but my suggestion is to check your wires.
NAVY99B4C is offline   Reply With Quote
Old 02-20-2010, 10:07 AM   #8
TECH Fanatic
iTrader: (2)
 
draggin97s10's Avatar
 
Join Date: Mar 2009
Posts: 1,471
Default

tune will never hurt
draggin97s10 is offline   Reply With Quote
Old 02-20-2010, 10:58 AM   #9
Launching!
Thread Starter
 
xxRONNIExx's Avatar
 
Join Date: Jun 2009
Posts: 247
Default

Quote:
Originally Posted by draggin97s10 View Post
how did you extend the o2s
I bought o2 extensions for the front.

Quote:
Originally Posted by NAVY99B4C View Post
I had the same problem with my LT car after full exhaust. never could find the problem. mine backfied all the time. i changed plugs and wires and rerouted my wires so there were away from the headers and it hasnt done it since. I think the heat broke down my wires really fast.

Id say a tune wouldnt hurt but my suggestion is to check your wires.
Yea I think thats a good idea. My wires are not touching but they are pretty close to the headers. I also think a tune would help as well...
xxRONNIExx is offline   Reply With Quote
Old 02-21-2010, 06:52 PM   #10
TECH Fanatic
iTrader: (2)
 
draggin97s10's Avatar
 
Join Date: Mar 2009
Posts: 1,471
Default

id try that. o2 extensions bought are good deal. alot easier then extending the harness.
draggin97s10 is offline   Reply With Quote
Reply


Tags
backfire, backfiring, gas, loud, loudmouth, lt1, occasional, rich, runs, slp

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 11:06 PM.