Go Back   LS1TECH > SBC-BBC-LT1-LT4 PERFORMANCE > LT1-LT4 Modifications
Sign in using an external account
Register Forgot Password?
Register iTraderTimeslips Photos Members Search Today's Posts Mark Forums Read Used CarsVendor Directory
Search

LT1-LT4 Modifications
1993-97 Gen II Small Block V8

Welcome to LS1Tech.com!
Welcome to LS1Tech.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join LS1Tech.com today!


Reply
 
Thread Tools Search this Thread
Old 02-07-2007, 09:06 PM   #1
TECH Veteran
Garage is empty, add now
 
Revelation Z28's Avatar
 
Trader Rating: 10
Join Date: Jul 2006
Location: Rialto CA
Posts: 4,767
Default signs of a bad oil pressure sensor

what are they? my needle dances sometimes on idle.
__________________

2006QSMPontiacGTOA4-Sold

2001 NBM Camaro SS M6 #4627: Volant CAI, factory LS6 intake, Ebay stainless LTs, pacesetter ORY, QTP 3" cutout always open, SLP dual dual, !CAGS, BMR LCA's, UMI STB, UMI RLB's, UMI PHR- SSold but not forgotten
Revelation Z28 is offline   Reply With Quote
Old 02-07-2007, 09:07 PM   #2
TECH Fanatic
Garage is empty, add now
 
streetwarrior96's Avatar
 
Trader Rating: 0
Join Date: Feb 2006
Posts: 1,124
Default

mine was pegged at the 80 psi side
streetwarrior96 is offline   Reply With Quote
Old 02-07-2007, 09:25 PM   #3
TECH Veteran
Garage is empty, add now
 
Revelation Z28's Avatar
 
Trader Rating: 10
Join Date: Jul 2006
Location: Rialto CA
Posts: 4,767
Default

well im thinking im getting a bad PSI reading. im hovering between 18 and 21psi on idle hot.

WOT im at 40 or 45.
__________________

2006QSMPontiacGTOA4-Sold

2001 NBM Camaro SS M6 #4627: Volant CAI, factory LS6 intake, Ebay stainless LTs, pacesetter ORY, QTP 3" cutout always open, SLP dual dual, !CAGS, BMR LCA's, UMI STB, UMI RLB's, UMI PHR- SSold but not forgotten
Revelation Z28 is offline   Reply With Quote
Old 02-07-2007, 09:29 PM   #4
TECH Fanatic
Garage is empty, add now
 
Ralls's Avatar
 
Trader Rating: 32
Join Date: Oct 2005
Location: Fairfax, Virginia
Posts: 1,677
Default

I idle at 19psi hot. I thought it was low but found out GM says its okay. Use a manual pressure guage, can't trust your gauges.
__________________

'94 383 Turbo Trans Am

"Look, laugh, but don't touch" - QOTSA
Ralls is offline   Reply With Quote
Old 02-07-2007, 09:37 PM   #5
TECH Regular
Garage is empty, add now
 
Trader Rating: 10
Join Date: Dec 2004
Location: oklahoma
Posts: 479
Default

you can find it the sending unit on the back of the drivers side head. you can grab it and see if the plastic body wiggles or if it feels like some oil has been leaking from it.

Thats how I just checked mine tonight since we had raised the motor to remove the pan to fix the pickup tube. I wanted to make sure we hadn't ran it into the firewall like I've done before.
__________________
05 quicksilver GTO m6 AZPS cam( 24~/24~ 111) fast 90 SW LT's ORX dual e cutouts 40 series, ram clutch rip shift drag bags, in dash touch screen nav. 452/410 rwhp/tq 11.71 at 118
95 T/A A4 red Sold
97 Formula T-top M6 cam(227/233 111LSA), long tubes, ported tb & intake bolt ons free mods 3in true duals Sold
99 WS6 trans am bought 3/1/06 T-top black M6 pacesetter LT's ORY elec cutout ported heads MS4 cam oil pump sold 6/13/07
97 Trans am Silver T-top M6 CC305 full bolt ons
lt1formula2000 is offline   Reply With Quote
Old 02-07-2007, 09:40 PM   #6
On The Tree
Garage is empty, add now
 
Trader Rating: 0
Join Date: Jul 2006
Location: Keego Harbor, Michigan
Posts: 174
Default

If it says 0 it's not working, lol happend to me. even before that though the dash would read 19-20 PSI hot, when at the same time the mechanical read 40
__________________
1996 CAMARO Z/28 M6
96mikez28 is offline   Reply With Quote
Old 02-07-2007, 11:04 PM   #7
TECH Veteran
Garage is empty, add now
 
Revelation Z28's Avatar
 
Trader Rating: 10
Join Date: Jul 2006
Location: Rialto CA
Posts: 4,767
Default

i want to clean the oil pump pickup screen, but i have no way of holding the engine up.

should i just leave it be or replace it? i think its the stocker still.
__________________

2006QSMPontiacGTOA4-Sold

2001 NBM Camaro SS M6 #4627: Volant CAI, factory LS6 intake, Ebay stainless LTs, pacesetter ORY, QTP 3" cutout always open, SLP dual dual, !CAGS, BMR LCA's, UMI STB, UMI RLB's, UMI PHR- SSold but not forgotten
Revelation Z28 is offline   Reply With Quote
Old 02-07-2007, 11:54 PM   #8
Launching!
Garage is empty, add now
 
Trader Rating: 1
Join Date: Jan 2006
Location: In a box next to walmart
Posts: 262
Default

mine was doing that just before the pump gear broke.
Imnotfast is offline   Reply With Quote
Old 02-07-2007, 11:54 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply

Tags
1996, 2001, 96, bad, camaro, lt1, oil, pressure, pump, sensor, signs, ss, switch, symptom, symptoms, z28


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 08:14 PM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.5.2
Advertising - Terms of Service - Privacy Statement - JOBS
Emails & Contact Details