T-56: Is having no oil in the shifter turret normal? [pic inside] - LS1TECH



Manual Transmission T56 | T5 | MN12 | Clutches | Hydraulics | Shifters
Sponsored by:
Sponsored by:

T-56: Is having no oil in the shifter turret normal? [pic inside]

Reply
 
Thread Tools Search this Thread
Old 03-11-2017, 09:31 PM   #1
Teching In
Thread Starter
iTrader: (2)
 
Join Date: Sep 2005
Location: Temecula, CA
Posts: 29
Question T-56: Is having no oil in the shifter turret normal? [pic inside]

Hi everyone!

I was in the process of installing a MGW shifter into my T-56. I noticed that there is no oil in the shifter turret. In other manual transmissions I've replaced the shifter on, I've always had some oil in the turret. Is this normal for the T-56?



Thanks in advance!
WaLieN is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
T56 Shifter Rattle - Not the shift Cup/Bushing? j498 Manual Transmission 0 04-20-2014 05:46 PM
My new N/A project.... (Update! Dyno results and engine bay pic pg3) CAMSTER Generation IV Internal Engine 285 08-12-2013 04:00 PM
Swarovski Z6i 2.5-15x56 HD Rifle Scope in PERFECT condition, 20 rounds DETROIT_AREA_00_SS Non-Automotive Classifieds 9 07-08-2012 02:30 PM
Corolla - Frozen Rear Suspension in Cold Weather? 105 Suspension & Brakes 8 01-17-2009 02:12 PM
What if? Dustin Racer's Lounge 11 10-11-2005 04:58 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 11:56 PM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send