Tranny Won't Shift! Please Help!!! - LS1TECH

Log In 


Manual Transmission a.sponlink:link {font-size: 9px;} img.surround{ border-color: #000000; border-width:1px; margin-bottom: 9.5px; } span.sponsortext { font-size: 10px; }
T56 | T5 | MN12 | Clutches | Hydraulics | Shifters
Sponsored by
McLeod Clutch

Tranny Won't Shift! Please Help!!!

Reply
 
Thread Tools Search this Thread
Old 09-01-2004, 03:30 PM   #1
Teching In
Thread Starter
 
LS1 Bandit's Avatar
 
Join Date: Aug 2004
Location: South Texas
Posts: 18
Question Tranny Won't Shift! Please Help!!!

I went with a heads and cam package and suddenly my car won't shift when rpm's are higher than 5k. The clutch (spec 3) pedal goes up and down perfectly. The shifter comes out of gear but won't go into the next one. There's no grinding. It's like I'm trying to throw it in gear without using the clutch. The strange part is that when I run on street tires, it shifts fine...the problem is only on my ET Streets. Only thing I do differently is that with my slicks, I smoke the tires and with the street tires, I only spin them to get the staging water off. Any ideas on how to fix this?
LS1 Bandit is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 06:11 PM.