Clutch has a grinding noise... - LS1TECH

Log In 


Manual Transmission T56 | T5 | MN12 | Clutches | Hydraulics | Shifters
Sponsored by:
Sponsored by:

Clutch has a grinding noise...

Reply
 
Thread Tools Search this Thread
Old 06-16-2005, 09:50 PM   #1
10 Second Club
Thread Starter
 
BAD FNZ's Avatar
 
Join Date: Aug 2004
Location: Houston
Posts: 328
Default Clutch has a grinding noise...

I stared the car up tonight after the drill mod...I thought it would fix my problem (posted about it in another thread) but it didn't... there's still no pedal pressure and when I put the car in reverse to back it out of the garage it made this awful scraping noise.... what is wrong with my clutch?!
BAD FNZ is offline   Reply With Quote
Old 06-16-2005, 10:55 PM   #2
TECH Addict
iTrader: (6)
 
P Mack's Avatar
 
Join Date: Jan 2003
Location: Phoenix
Posts: 2,384
Default

It will grind if your clutch isn't disengaging, and chances are if you have no pedal pressure the clutch isn't disengaging. I would say bench bleed the master cylinder in the car and try again.

Just read your other thread, I don't know how you'd get air in your system all of a sudden like that, but it's worth a shot bleeding it.
P Mack is offline   Reply With Quote
Old 06-16-2005, 11:06 PM   #3
10 Second Club
Thread Starter
 
BAD FNZ's Avatar
 
Join Date: Aug 2004
Location: Houston
Posts: 328
Default

thanks for the info bro
BAD FNZ is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 06:06 PM.