Neutral + Clutch In = Stall - LS1TECH

Log In 


Manual Transmission T56 | T5 | MN12 | Clutches | Hydraulics | Shifters
Sponsored by:
Sponsored by:

Neutral + Clutch In = Stall

Reply
 
Thread Tools Search this Thread
Old 10-13-2006, 02:08 PM   #1
On The Tree
Thread Starter
 
Join Date: Jan 2004
Location: Houston/ Austin, TX
Posts: 188
Default Neutral + Clutch In = Stall

As the title says. When Im in gear OR neutral and push the clutch in, the call shakes violently and dies. I also cant start the motor by pressing in the clutch.

Ive done some reading and Im pretty sure the bolt that holds the clutch fork down came loose.

Does this sound right to anyone else?

(This is a Ram Powergrip HD clutch on an LT1)
disco192 is offline   Reply With Quote
Old 10-13-2006, 04:45 PM   #2
Teching In
 
malott442's Avatar
 
Join Date: Jun 2005
Location: Attleboro, MA
Posts: 39
Default

Are there any noises (metallic, clunking), associated with the shake n' die????? Sounds pretty interesting
malott442 is offline   Reply With Quote
Old 10-13-2006, 04:51 PM   #3
On The Tree
Thread Starter
 
Join Date: Jan 2004
Location: Houston/ Austin, TX
Posts: 188
Default

Its hard to say... Before it died, the car was making an odd high pitched noise that was on and off.

The day it died, there was a serious shaking when the clutch was pressed in, but I couldnt hear much. My car is pretty loud (383 w/ 4" exhaust).

Hopefully it will be fixed tonight. I will keep you guys posted.
disco192 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 02:03 PM.