help! fast tb.... - LS1TECH

Go Back   LS1TECH > WELCOME TO LS1TECH > New LS1 Owners - Newbie Tech
Sign in using an external account
Register Forgot Password?
Search


New LS1 Owners - Newbie Tech
Basic Technical Questions & Advice
Sponsored by
Improved Racing


help! fast tb....

Reply
 
Thread Tools Search this Thread
Old 01-24-2010, 05:52 PM   #1
Teching In
 
Trader Rating: 0
Join Date: Jan 2010
Location: San Jo
Posts: 9
Default help! fast tb....

Got a fast intake n throttle body. peddle to metal and tb wont open all the way. only half way. any solutions?
__________________
99RS is offline   Reply With Quote
Old 01-24-2010, 06:18 PM   #2
TECH Enthusiast
 
jdiddyws6's Avatar
 
Trader Rating: 5
Join Date: Jun 2006
Location: Long Beach MS/Birmingham AL
Posts: 637
Send a message via AIM to jdiddyws6
Default

Is the tb cam hitting anything?
jdiddyws6 is offline   Reply With Quote
Old 01-24-2010, 06:21 PM   #3
Teching In
 
Trader Rating: 0
Join Date: Jan 2010
Location: San Jo
Posts: 9
Default

Quote:
Originally Posted by jdiddyws6 View Post
Is the tb cam hitting anything?
nope. its hittin nothin. i was thinkin maybe the throttle cable is too long or the spindle thing is too big. i was jus wanted to know if anybody had same problem and wut did they do to fix it, like if they modified it or bought something to make it work properly...
__________________
99RS is offline   Reply With Quote
Old 01-24-2010, 06:23 PM   #4
TECH Enthusiast
 
jdiddyws6's Avatar
 
Trader Rating: 5
Join Date: Jun 2006
Location: Long Beach MS/Birmingham AL
Posts: 637
Send a message via AIM to jdiddyws6
Default

I had the same problem. One of the worm clamps for the bellows was obstructing then movement of the tb cam.
jdiddyws6 is offline   Reply With Quote
Old 01-24-2010, 06:23 PM   #5
Teching In
 
Trader Rating: 0
Join Date: Jan 2010
Location: San Jo
Posts: 9
Default

anyone?
__________________
99RS is offline   Reply With Quote
Old 01-24-2010, 06:24 PM   #6
Teching In
 
Trader Rating: 0
Join Date: Jan 2010
Location: San Jo
Posts: 9
Default

Quote:
Originally Posted by jdiddyws6 View Post
I had the same problem. One of the worm clamps for the bellows was obstructing then movement of the tb cam.
nothin in da way on mine.
__________________
99RS is offline   Reply With Quote
Old 01-24-2010, 06:31 PM   #7
Moderator
 
SweetS10V8's Avatar
 
Trader Rating: 4
Join Date: Jun 2004
Location: Michigan
Posts: 2,585
Default

Does it open all the way if you take it off the car and try it??
__________________
Quote:
Originally Posted by John Lingenfelter
The world's best cam combined with a poor set of heads will produce an engine that's a dog. But bolt on a set of great heads even with a poor cam, and that engine will still make great power.
SweetS10V8 is offline   Reply With Quote
Old 01-24-2010, 06:44 PM   #8
Teching In
 
Trader Rating: 0
Join Date: Jan 2010
Location: San Jo
Posts: 9
Default

Quote:
Originally Posted by SweetS10V8 View Post
Does it open all the way if you take it off the car and try it??
it open just only a little bit more. still not all the way.
__________________
99RS is offline   Reply With Quote
Old 01-25-2010, 01:18 AM   #9
Teching In
 
Trader Rating: 0
Join Date: Jan 2010
Location: San Jo
Posts: 9
Default

anyone?
__________________
99RS is offline   Reply With Quote
Old 01-25-2010, 08:58 AM   #10
Internet Mechanic
 
BlackScreaminMachine's Avatar
 
Trader Rating: 17
Join Date: May 2005
Location: Wallingford CT
Posts: 9,841
Default

Pics please.

Techincially they only open half way lol. But joking aside, when I had my BBK TB on mt LT1, if I put the cable in the wrong slot (it had 2), it would do the same. Does your Fast have 2 spots where you can connect the Throttle Cable?
__________________
2002 NBM Trans Am SOLD!

http://ls1tech.com/forums/vehicle-cl...l#post17273103
BlackScreaminMachine is offline   Reply With Quote
Old 01-25-2010, 07:08 PM   #11
Moderator
 
SweetS10V8's Avatar
 
Trader Rating: 4
Join Date: Jun 2004
Location: Michigan
Posts: 2,585
Default

Quote:
Originally Posted by 99RS View Post
it open just only a little bit more. still not all the way.
Its not put together correctly, someone took it apart and didnt set the return spring right.. Ive seen this before a long time ago.
__________________
Quote:
Originally Posted by John Lingenfelter
The world's best cam combined with a poor set of heads will produce an engine that's a dog. But bolt on a set of great heads even with a poor cam, and that engine will still make great power.
SweetS10V8 is offline   Reply With Quote
Old 01-25-2010, 07:08 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


 

All times are GMT -5. The time now is 07:37 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details