Tcs - LS1TECH

Log In 


New LS1 Owners - Newbie Tech Basic Technical Questions & Advice
Sponsored by:
Sponsored by:

Tcs

Reply
 
Thread Tools Search this Thread
Old 07-15-2011, 01:41 AM   #1
12 Second Club
Thread Starter
iTrader: (10)
 
99Z28camaroman's Avatar
 
Join Date: Sep 2005
Location: United Kingdom, England
Posts: 343
Default Tcs

Hey guys, I've been a way for a while as I had a classic 67 Firebird Convertable the last 2 years and a C5 Vette before that.

I juat got a 98 Trans Am it has an SLP air lid and a WS6 hood and a set of Torque thrust II alloys.

It has a TCS button but it does not work so the TCS light is on!
Most of you guys probably think this is a good thing. when you press the TCS button nothing happens. Is it normal for the TCS to default to off if the switch is faulty?

I tried removing the switch to look at it there are about 5 pins and wires on there! How do I test it to see if it's broke. I have a test meter.
99Z28camaroman is offline   Reply With Quote
Old 07-15-2011, 04:55 AM   #2
The Scammer Hammer
iTrader: (48)
 
dr_whigham's Avatar
 
Join Date: Apr 2009
Location: Lafayette, LA
Posts: 6,160
Default

Did you check to see if maybe the previous owner installed an SLP TCS Logic Module?

http://www.slponline.com/view_product_site.asp?P=63015
dr_whigham is offline   Reply With Quote
Old 07-15-2011, 04:57 AM   #3
TECH Resident
iTrader: (6)
 
oChristiano's Avatar
 
Join Date: Sep 2008
Location: SoCal, SFV
Posts: 792
Default

^thats what I was gunna say. When you click it does tcs turn on?
oChristiano is offline   Reply With Quote
Old 07-16-2011, 01:27 AM   #4
12 Second Club
Thread Starter
iTrader: (10)
 
99Z28camaroman's Avatar
 
Join Date: Sep 2005
Location: United Kingdom, England
Posts: 343
Default

The previous owner thought the TCS was turned off some how! So I don't think it has an SLP module he didn't know what an SLP module was until I said about it!. When you press the TCS button nothing happens. There is no light on the button and the dash still says TCS off.

I thought the TCS was default on and you had to switch it off! What I'm thinking if the switch is broken it must default to off. I thought it could not be turned off in the PCM you had to get one of the SLP modules to switch it's default setting from on to off!

If it does have an SLP module the switch should still work! Where would the SLP module be if it has one?

I wanted to test my TCS switch with a meter to see if it works but I don't know how? I could just get a TCS switch and try it but it would be a waste of money if there is nothing wrong with the one I have.

Remember I am in the UK and would have to get a TCS switch sent from the USA!
99Z28camaroman is offline   Reply With Quote
Old 07-16-2011, 03:50 AM   #5
The Scammer Hammer
iTrader: (48)
 
dr_whigham's Avatar
 
Join Date: Apr 2009
Location: Lafayette, LA
Posts: 6,160
Default

If it has the module you'd see it sitting right on top of the radio. The harness for those things are really short to begin with.

If you don't see anything extra plugged in, I think it's safe to say your switch is probably faulty.
dr_whigham is offline   Reply With Quote
Old 07-21-2011, 01:14 AM   #6
12 Second Club
Thread Starter
iTrader: (10)
 
99Z28camaroman's Avatar
 
Join Date: Sep 2005
Location: United Kingdom, England
Posts: 343
Default

I had a look for an SLP module but I coundn't even get the radio bezel off!
I got a good deal on a used TCS switch so I will fit it when it arrives, maybe that will cure it!
99Z28camaroman is offline   Reply With Quote
Old 08-03-2011, 01:28 AM   #7
12 Second Club
Thread Starter
iTrader: (10)
 
99Z28camaroman's Avatar
 
Join Date: Sep 2005
Location: United Kingdom, England
Posts: 343
Default

Well my replacement TCS switch arrived from the USA and I fitted it and guess what still the same! The dash says TCS off no lights on the switch and nothing happens when you press the TCS switch!

Anyone have any suggestions on what to check next?
99Z28camaroman is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Other uses for TCS button - Firebird/TA kgkern01 Stereo & Electronics 3 05-23-2014 04:16 PM
TCS Button Light? 777Shock777 General Maintenance & Repairs 2 07-09-2013 02:15 AM
wtb - TCS switch and bezel Screamin LS1 SS Parts Wanted 0 09-06-2012 10:53 AM
Wiring TCS Switch 1998silverbird Stereo & Electronics 7 09-06-2010 05:18 PM
I need help 911 Pep Boys Murdered my 01 SOM Trans AM Scarlet_Spider General Maintenance & Repairs 16 06-01-2009 11:36 PM


Tags
98, activate, c5, camaro, enable, firebird, ii, light, pontiac, tcs, thrust, torq, torque, wheels, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 11:00 AM.