stupid dealer sucks at everything! (long) - LS1TECH

Go Back   LS1TECH > WELCOME TO LS1TECH > New LS1 Owners - Newbie Tech
Log In 
Search


New LS1 Owners - Newbie Tech
Basic Technical Questions & Advice
Sponsored by
Improved Racing


stupid dealer sucks at everything! (long)

Reply
 
Thread Tools Search this Thread
Old 05-23-2004, 12:46 AM   #1
11 Second Club
 
blkZ28spt's Avatar
 
Trader Rating: 0
Join Date: Feb 2003
Location: The South
Posts: 5,520
Send a message via AIM to blkZ28spt
Default stupid dealer sucks at everything! (long)

Okay, here's the short version of what they've done wrong:

1) My car was at home while I was at school for winter months. My parents took it to and picked it up from a local dealer for me as it needed the back fixed after I got rear-ended last fall (story ALL it's own, trust me). They didn't even fix it completely, had to take it there twice (the service manager from the first time had been fired) and its really close but NOT totally fixed and I myself can tell pretty easily.

2) I had been having problems with the the battery dying and the car not starting if I left it for even one day without driving, and sometimes it died during a long day of work, etc. I thought the battery or alt to blame, they said my SLP fan switch had gone bad and was draining constantly, so they unhooked it. It was better, but was still dying when I left it for a full day and once just overnight. Went to autozone, they said battery was bad, got a new one, problem 100% fixed.

3) I realized, about 2 weeks ago, that my left rear tire (nitto DR) was completely bald in between the two outermost lines. (I had not noticed since the outer edge was just fine, and that was all i normally saw and i never specifically checked the inside part or looked at it from far enough away from behind to see it) I could not figure out why, the right tire is jsut fine and they only have 5,xxx miles on them with no track passes little racing and only 2 burnouts. Checked tire pressures today, and that bald nitto was 42 psi cold!! and the front tires (BFG KDW) were also over 40 psi cold, the "good" treaded nitto was 18 psi cold which is about where I ahd left it. (normally kept front tires at 32 psi, nittos 18-22). I mentioned this to my dad and he was like "oh yeah the guy did put air in them before we picked it up he said they were low."
AHHHHH so now I ahve one good nitto and one bald nitto and a not totally fixed messed up back end and i don't know if my slp fan switch is really bad or not. I am learning that my being **** about my car and who can do anything with it is justified I can't trust anybody to not screw something up, even if it's unrelated to what they are suppose to be doing!!!!!!

Edit: Everybody (except Tire Rack) that I have trusted my car to has messed something up, whether it be big or small, that I did not like. LS1speed, the dealer, a different tire dealer/installer, the muffler shop that put my Loudmouth on, the muffler shop that cut my loudmouth off, etc. Why does this happen?!

(my car is still going back to LS1speed though, they did a good job all in all)
(and yes my dad is at least 50% to blame for the tire thing, they did tell him when he picked it up but he doesn't know crap and didn't tell me when I came home) *sigh*
__________________
Sold: 1998 Z28: NA Cam only A4. 385rwhp. 7.59/11.92
Black 2005 Explorer 4x4 V8
Silver 2011 Yukon XL 4x4 5.3

Last edited by blkZ28spt; 05-23-2004 at 12:57 AM.
blkZ28spt is offline   Reply With Quote
Old 05-23-2004, 12:59 AM   #2
Teching In
 
Trader Rating: 0
Join Date: May 2004
Posts: 17
Default

This is why I do all the work I can myself, and if I have to take it some where they normaly don't like me to much cause I'm sitting on their sholders the whole time watching.
Outlaw13 is offline   Reply With Quote
Old 05-23-2004, 01:07 AM   #3
11 Second Club
 
blkZ28spt's Avatar
 
Trader Rating: 0
Join Date: Feb 2003
Location: The South
Posts: 5,520
Send a message via AIM to blkZ28spt
Default

Quote:
Originally Posted by Outlaw13
This is why I do all the work I can myself, and if I have to take it some where they normaly don't like me to much cause I'm sitting on their sholders the whole time watching.
Yeah, that is how I am going to have to do it most of the time I am afraid.
EVERYBODY messes something up:
Dealer: left me with visible signs of rear end collision if you look at all, caused me to lose much tread life on one nitto.
ls1Speed Gave me 3" duals all the way when agreement was for 3" into X and 2.5" out of X. Wonder how much ground clearance I lost, esp when i scrape turn-downs on speed bumps at school.
Tire dealer/installer Got some scrapes on my wheels.
Muffler shop Cut my loudmouth when/where I specifically told them not to even if they had to I'd rather have it stay on than be cut off where they did, and they cut all the clamps that I wanted to be unscrewed/unbolted so they could be re-used.
Will this ever end?!?!?! This should serve as notice to those of you who hae not figured this out for yourself, you can NOT assume that anybody knows what they are doing well enough to do it right, no matter what, even if you told them waht to do!
__________________
Sold: 1998 Z28: NA Cam only A4. 385rwhp. 7.59/11.92
Black 2005 Explorer 4x4 V8
Silver 2011 Yukon XL 4x4 5.3
blkZ28spt is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


 

All times are GMT -5. The time now is 11:11 AM.


Powered by vBulletin® Version 3.8.7 AC2
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details