Coolant light, need some help - LS1TECH

Log In 


New LS1 Owners - Newbie Tech Basic Technical Questions & Advice
Sponsored by:
Sponsored by:

Coolant light, need some help

Reply
 
Thread Tools Search this Thread
Old 04-16-2005, 07:22 PM   #1
CT Hotness
Thread Starter
iTrader: (5)
 
lilstephsls1's Avatar
 
Join Date: Jul 2004
Location: Bristol, CT
Posts: 2,480
Default Coolant light, need some help

I did a search but i didn't really get any results that left me confident, so here we go. today i was driving and my coolant light went on. The coolant was fairly full but i added some more in. Anyways, as the manual said, all i would need for the light to go off is shut off the ignition and restart it. I've done this several times and the light won't shut off. Could there be something wrong with a sensor or something as well or is this light like the SES light that never goes out until you tune it out? thanks in advance for all the feedback
-steph
lilstephsls1 is offline   Reply With Quote
Old 04-16-2005, 07:26 PM   #2
TECH Junkie
iTrader: (17)
 
My84Z's Avatar
 
Join Date: Sep 2003
Location: Dartmouth, Mass
Posts: 3,004
Default

slowhawk will be able to scan it or reset it for ya and let ya know tommorow. you can also try resetting the pcm.
My84Z is offline   Reply With Quote
Old 04-16-2005, 07:35 PM   #3
11 Second Club
iTrader: (8)
 
LiquidFire350's Avatar
 
Join Date: Aug 2004
Location: Montgomery, IL
Posts: 1,831
Default

happens to my dads car all the time, he just restarts it, but your light wont go out, even if you let it sit for a while?, id think its the sensor, i wouldnt tune that light out, its a nice warning light to have if your not paying attention to the water level

did you do anything to the car lately, or did it just pop on one day, if it just popped on and wont turn off, id have the sensor checked out, or replaced if its cheap
LiquidFire350 is offline   Reply With Quote
Old 04-17-2005, 07:16 AM   #4
TECH Fanatic
iTrader: (2)
 
ddelallata's Avatar
 
Join Date: Mar 2004
Location: Brownsville, Tx
Posts: 1,462
Default

Just unplug the connecter. you'll find it on the radiator next to the battery. Unplugging it will turn off the light.
ddelallata is offline   Reply With Quote
Old 04-17-2005, 09:25 AM   #5
TECH Resident
iTrader: (2)
 
SStheBest's Avatar
 
Join Date: Feb 2005
Location: Navarre, FL
Posts: 982
Default

damn guys....GM put sensors like this on these cars for a reason.....im guessin bad sensor...but id have it looked at...to many bad things happen to people when a problem arises...and half *** it on going about getting it fixed
SStheBest is offline   Reply With Quote
Old 04-17-2005, 09:52 AM   #6
TECH Fanatic
iTrader: (2)
 
ddelallata's Avatar
 
Join Date: Mar 2004
Location: Brownsville, Tx
Posts: 1,462
Default

Quote:
Originally Posted by SStheBest
damn guys....GM put sensors like this on these cars for a reason.....im guessin bad sensor...but id have it looked at...to many bad things happen to people when a problem arises...and half *** it on going about getting it fixed
they put it there to just to cause problems. That's why the newer LS1s didn't get a coolant level sensor.
ddelallata is offline   Reply With Quote
Old 04-17-2005, 12:44 PM   #7
TECH Regular
iTrader: (2)
 
Kurt D's Avatar
 
Join Date: Nov 2001
Location: Pineville, La
Posts: 487
Default

Quote:
Originally Posted by ddelallata
they put it there to just to cause problems. That's why the newer LS1s didn't get a coolant level sensor.


Just unplug it. I had my old `99's cleaned and replaced several times, finaly said screw it after the warranty ran out. My `02 doesn't have it, GM droped the sensor after `99.
Kurt D is offline   Reply With Quote
Old 04-18-2005, 10:26 AM   #8
CT Hotness
Thread Starter
iTrader: (5)
 
lilstephsls1's Avatar
 
Join Date: Jul 2004
Location: Bristol, CT
Posts: 2,480
Default

haha, the thing is being a pain, its going on and off, im just going to unplug it... stupid things make me worry too much
lilstephsls1 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 01:57 PM.