Go Back   LS1TECH > WELCOME TO LS1TECH > New LS1 Owners - Newbie Tech
Sign in using an external account
Register Forgot Password?
Search

New LS1 Owners - Newbie Tech
Basic Technical Questions & Advice
Sponsored by
Improved Racing

Magic Coolant???

Reply
 
Thread Tools Search this Thread
Old 09-09-2006, 07:03 PM   #1
Teching In
 
speedfrk77's Avatar
 
Trader Rating: 0
Join Date: Jan 2006
Location: Macungie Pa
Posts: 14
Send a message via AIM to speedfrk77
Default Magic Coolant???

Today I took my Z-28 to gets its oil changed. When the coolant was checked, they said that it was bone dry.
I had the car in for a check up this past month and it was full and good for -20 degrees. There was no coolant puddles under my car.

Has anyone else experienced this problem? Thoughts on what it could be?
__________________
Eric

99 Z28
Bone stock
speedfrk77 is offline   Reply With Quote
Old 09-09-2006, 07:39 PM   #2
Banned
 
BLKWS.6's Avatar
 
Trader Rating: 0
Join Date: Dec 2004
Posts: 2,636
Send a message via AIM to BLKWS.6
Default

It COULD be a lying tech. Why dont you visually/physically verify this. When I took my 5.0 to MY OWN dealership that I worked for for a year (and was in good standing with at that time and currently) they lied to me BIG TIME "Sir, we found no codes on the OBDI scanner"

I went and payed ANOTHER $30 and got one myself...it pulled so many codes that I now have a carb.
BLKWS.6 is offline   Reply With Quote
Old 09-09-2006, 07:56 PM   #3
TECH Senior Member
 
Trader Rating: 0
Join Date: Dec 2001
Location: Jacksonville, FL
Posts: 5,402
Default

Make sure it's topped off and check it yourself for a while. If the low coolant sensor is still plugged in should've thrown a low coolant light too.
2001NBMZ28 is offline   Reply With Quote
Old 09-10-2006, 01:08 AM   #4
LS1Tech Administrator
 
RPM WS6's Avatar
 
Trader Rating: 3
Join Date: Nov 2001
Location: Lincolnwood, IL Member: #317
Posts: 20,541
Default

Quote:
Originally Posted by speedfrk77
Today I took my Z-28 to gets its oil changed. When the coolant was checked, they said that it was bone dry.
I find that hard to beleive. Perhaps they meant that the coolant overflow bottle was bone dry. No way in hell was the entire cooling system bone dry without you experiancing some serious overheating issues.
__________________
1998 Camaro Z28 | 1971 Nova SS-350



Previous LSx Vehicles:
2002 Camaro Z28 | 2000 Trans Am WS6 | 1999 Camaro Z28
RPM WS6 is offline   Reply With Quote
Old 09-11-2006, 09:37 PM   #5
Teching In
 
speedfrk77's Avatar
 
Trader Rating: 0
Join Date: Jan 2006
Location: Macungie Pa
Posts: 14
Send a message via AIM to speedfrk77
Default

The overflow and my radiator were dry and my low collant light never went on. My temp was still between 200 and 210. I just can't see how it was that low
__________________
Eric

99 Z28
Bone stock
speedfrk77 is offline   Reply With Quote
Old 09-11-2006, 10:04 PM   #6
On The Tree
 
The Butcher's Avatar
 
Trader Rating: 0
Join Date: Sep 2006
Location: Warsaw, IN
Posts: 163
Default

Well, first things first. If your coolant was empty, were did it go? It's good for 7 years...it doesn't evaporate. Having worked at a dealership myself, I can follow with what Stanger88 is saying. I had guys that worked with me tell me ALL KINDS of b.s. stories, so I could imagine what they would say to someone they assume doesn't know as much as them. Some one just wanted to nickel and dime ya so they could get some extra $$$ from ya for coolant. Overflow bottles are pretty much just that. They can be empty, in fact every car I've ever built that was onna the first things to "get lost".
__________________
Quote:
Originally Posted by Trey_Z28
What you've just said is one of the most insanely idiotic things I have ever heard. At no point in your rambling, incoherent response were you even close to anything that could be considered a rational thought. Everyone in this room is now dumber for having listened to it. I award you no points, and may God have mercy on your soul.
[/center]
The Butcher is offline   Reply With Quote
Old 09-12-2006, 12:23 AM   #7
On The Tree
 
will350wax's Avatar
 
Trader Rating: 21
Join Date: Mar 2006
Location: Waxahachie/Henderson
Posts: 154
Default

I had a very tiny leak in my 02 SS's radiatior. It never leaked on the ground but when it was hot it would "mist" out. Never made a puddle, but it got to where I would add a galon every other day. They could be jerking your chain or you might have a small leak.
will350wax is offline   Reply With Quote
Old 09-12-2006, 07:59 AM   #8
TECH Resident
 
blackfang's Avatar
 
Trader Rating: 2
Join Date: Jul 2002
Location: Richmond, VA
Posts: 885
Default

Did you check it yourself?
__________________

Richmond Performance Musclecars | Pics
2009 Vulcan 900 Custom
2007 Subaru Legacy 2.5i The daily
1998 Z/28 hardtop A4- SLP Lid, Magnaflow catback, cutout, Hotchkis LCA'S/PHB, BMR TA and D/S Loop, Y2K C5 wheels, Tuned by Frost 300rwhp/308rwtq........13.33@104
blackfang is offline   Reply With Quote
Old 09-12-2006, 11:43 AM   #9
Staging Lane
 
Trader Rating: 0
Join Date: Jun 2006
Posts: 68
Default

I'm sure it's fine.
charger01 is offline   Reply With Quote
Old 09-12-2006, 07:10 PM   #10
Teching In
 
speedfrk77's Avatar
 
Trader Rating: 0
Join Date: Jan 2006
Location: Macungie Pa
Posts: 14
Send a message via AIM to speedfrk77
Default

I checked it the next day and both the overflow and the radiator were still full and there was no puddle. I am going to check it this weekend.
__________________
Eric

99 Z28
Bone stock
speedfrk77 is offline   Reply With Quote
Old 09-13-2006, 09:32 AM   #11
TECH Resident
 
blackfang's Avatar
 
Trader Rating: 2
Join Date: Jul 2002
Location: Richmond, VA
Posts: 885
Default

I have worked with some shady Techs though.
__________________

Richmond Performance Musclecars | Pics
2009 Vulcan 900 Custom
2007 Subaru Legacy 2.5i The daily
1998 Z/28 hardtop A4- SLP Lid, Magnaflow catback, cutout, Hotchkis LCA'S/PHB, BMR TA and D/S Loop, Y2K C5 wheels, Tuned by Frost 300rwhp/308rwtq........13.33@104
blackfang is offline   Reply With Quote
Old 09-13-2006, 09:32 AM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 12:14 PM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details