Go Back   LS1TECH > LS1-LS2-LS3-LS6-LS7 PERFORMANCE > Nitrous Oxide
Sign in using an external account
Register Forgot Password?
Search

Nitrous Oxide
Installation | Tuning | Products

Anybody fouled up a plug before?

Reply
 
Thread Tools Search this Thread
Old 08-11-2004, 11:36 PM   #1
Launching!
 
Buff's Avatar
 
Trader Rating: 0
Join Date: Jul 2003
Location: Raleigh, NC
Posts: 247
Default Anybody fouled up a plug before?

After running the nitrous the other day on my way home, the engine light started to come on intermittantly. yesterday it didn't come on at all driving around the neighborhood.

Well, I am on the way to work tonight the light came back on. From a stop to a cruising speed, you can feel the engine running rough but once you get to a cruising speed, it runs ok IMO.

any suggestions?
__________________
2013 60th annivesary edition 427 Vert
Katech torque cam, WCCH heads, halltech CAI, Kooks headers w/cats
546rwhp/493 tq
Buff is offline   Reply With Quote
Old 08-11-2004, 11:36 PM
LS1Tech
Pontiac Firebird




Paid Advertisement
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Join Ls1Tech

All times are GMT -5. The time now is 08:52 AM.


Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Advertising - Terms of Service - Privacy Statement - Terms of Service - JOBS
Emails & Contact Details